Problem only when using extDB

Problem only when using extDB

« posted: May 21, 2016, 06:38 AM »
Hi A3Wasteland Community,

I've recently been working on porting A3Wastland to Zargabad as a fun little project. All has been going well until I ran into a little problem today when attempting to use extDB.

Basically, in the "main_config.sqf" in the "A3Wasteland_settings" folder when I change A3W_savingMethod = "profile"; to A3W_savingMethod = "extDB"; (under //Persistence Settings) the game will hang on the "Please wait for you client to initialize" screen after joining and choosing my character. This doesn't happen when the saving method is set to "profile". Any help would be greatly appreciated because I am stumped!

Thanks in advance,
Alex

Re: Problem only when using extDB

« Reply #1 posted: May 22, 2016, 01:59 AM »
it does that if it cant connect to your mysql database

you need to setup the database and point the extdb-conf.ini to your database

all items in red need to be changed to point to your database

+;################################################################################################################################
 +;##                                                                                                                            ##
 +;##    A3WASTELAND DATABASE                                                                                                    ##
 +;##                                                                                                                            ##
 +
 +[A3W]
 +Type = MySQL
 +Name = a3wasteland
 +
 +Username = root
 +Password = password
 +
 +IP = 127.0.0.1
 +Port = 3306
 +
 +;minSessions = 2
 +idleTime = 60
 +
 +compress = false
 +; Really should only use this if MySQL server is external. Also only for MySQL
 +
 +Secure Auth = true
 +; Recommend you turn this on  http://dev.mysql.com/doc/refman/5.6/en/mysql-command-options.html#option_mysql_secure-auth
 +
 +;##                                                                                                                            ##
 +;##                                                                                                                            ##
 +;################################################################################################################################


here is wasteland release info might help you out
https://github.com/A3Wasteland/Release_Files



Re: Problem only when using extDB

« Reply #2 posted: May 22, 2016, 07:33 PM »
it does that if it cant connect to your mysql database

you need to setup the database and point the extdb-conf.ini to your database

all items in red need to be changed to point to your database

+;################################################################################################################################
 +;##                                                                                                                            ##
 +;##    A3WASTELAND DATABASE                                                                                                    ##
 +;##                                                                                                                            ##
 +
 +[A3W]
 +Type = MySQL
 +Name = a3wasteland
 +
 +Username = root
 +Password = password
 +
 +IP = 127.0.0.1
 +Port = 3306
 +
 +;minSessions = 2
 +idleTime = 60
 +
 +compress = false
 +; Really should only use this if MySQL server is external. Also only for MySQL
 +
 +Secure Auth = true
 +; Recommend you turn this on  http://dev.mysql.com/doc/refman/5.6/en/mysql-command-options.html#option_mysql_secure-auth
 +
 +;##                                                                                                                            ##
 +;##                                                                                                                            ##
 +;################################################################################################################################


here is wasteland release info might help you out
https://github.com/A3Wasteland/Release_Files

I'm pretty sure that I have set up everything correctly. Could the problem be that I am on my University's school network? When I launch my MySQL workbench I get this warning (attached):
  • Offline Mooney
  • First Blood
  • ***
  • Posts: 56

Re: Problem only when using extDB

« Reply #3 posted: May 22, 2016, 07:45 PM »
What version is your MySQL server?

Re: Problem only when using extDB

« Reply #4 posted: May 22, 2016, 07:47 PM »
What version is your MySQL server?

Under System Info it says
MySQL Workbench Community (GPL) for Windows version 6.2.5  revision 0 build 397 (64 bit)
So 6.2.5?

Re: Problem only when using extDB

« Reply #5 posted: May 22, 2016, 08:05 PM »
Woops, that was my Workbench version. I checked and realized my server version did indeed need to be updated/was corrupted, so I did a complete reinstall of all the MySQL apps and everything is working perfectly. Thanks!