extDB doesn't save between restarts

extDB doesn't save between restarts

« posted: Jun 21, 2016, 07:39 PM »
First I'd like to say sorry for my english its not the best. So I know some stuff about linux and mysql but somehow wasteland doesn't write data to it in the console I get the error  "Warning Message: Problem occurred when saving profile data. The file may be set to read-only or can be blocked by another instance of the game (e.g., dedicated server)" Is this message related to the problem ? I am running on centos 7 also when I join and my characters data gets saved you should immediately see a line added in the database right ? (using phpmyadmin to check) What am I doing wrong help would be appreciated.

Re: extDB doesn't save between restarts

« Reply #1 posted: Jun 21, 2016, 10:57 PM »
First I'd like to say sorry for my english its not the best.
Seems fine to me :)

So I know some stuff about linux and mysql but somehow wasteland doesn't write data to it in the console I get the error  "Warning Message: Problem occurred when saving profile data. The file may be set to read-only or can be blocked by another instance of the game (e.g., dedicated server)" Is this message related to the problem ?
Probably, yes.
edit: now come to think about it, this might also be a permissions issue since you are running linux

I am running on centos 7 also when I join and my characters data gets saved you should immediately see a line added in the database right ? (using phpmyadmin to check)
Yes.

What am I doing wrong help would be appreciated.

Ok so can you either paste your entire rpt log file in pastebin or look for the extDB initialisation message? That will tell us more.
Administrator with the  Howling Maggots community

  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2489

Re: extDB doesn't save between restarts

« Reply #2 posted: Jun 22, 2016, 02:00 AM »
if it says "profileNamespace", it means you aren't even using extDB. Look earlier in the log during startup to see what's the problem.

Re: extDB doesn't save between restarts

« Reply #3 posted: Jun 22, 2016, 12:27 PM »
if it says "profileNamespace", it means you aren't even using extDB. Look earlier in the log during startup to see what's the problem.

Found out that the mods A3Wasteland_settings and extDB are false and not found http://pastebin.com/PaqXHTSK looking into it now.

This is my launch script http://pastebin.com/NdWt6jSR I tried inserting the entire path for the mods but they still don't get detected what am I doing wrong here ?

Re: extDB doesn't save between restarts

« Reply #4 posted: Jun 22, 2016, 12:42 PM »
Seems fine to me :)
Probably, yes.
edit: now come to think about it, this might also be a permissions issue since you are running linux
Yes.

Ok so can you either paste your entire rpt log file in pastebin or look for the extDB initialisation message? That will tell us more.

I found out by the help of AgentRev that extDB isnt even loaded in http://pastebin.com/PaqXHTSK for some reason it doesn't find the path to the mods.

Re: extDB doesn't save between restarts

« Reply #5 posted: Jun 22, 2016, 01:23 PM »
Found out that the mods A3Wasteland_settings and extDB are false and not found http://pastebin.com/PaqXHTSK looking into it now.

This is my launch script http://pastebin.com/NdWt6jSR I tried inserting the entire path for the mods but they still don't get detected what am I doing wrong here ?

You dont need extdb as a mod. its just a folder in your arma 3 server folder just like mpmissions is. if you dont have that i suggest you take a look over here https://github.com/A3Wasteland/Release_Files
Administrator with the  Howling Maggots community

Re: extDB doesn't save between restarts

« Reply #6 posted: Jun 22, 2016, 01:28 PM »
You dont need extdb as a mod. its just a folder in your arma 3 server folder just like mpmissions is. if you dont have that i suggest you take a look over here https://github.com/A3Wasteland/Release_Files

But if I remember correctly A3Wasteland_settings is supposed to be a mod right ? My server
directory looks like this : http://pastebin.com/SHXYEr8x

Re: extDB doesn't save between restarts

« Reply #7 posted: Jun 22, 2016, 01:34 PM »
But if I remember correctly A3Wasteland_settings is supposed to be a mod right ? My server
directory looks like this : http://pastebin.com/SHXYEr8x

No, wasteland does not require mods. Just read the IMPORTANT.TXT in the github repository i linked.
Administrator with the  Howling Maggots community

Re: extDB doesn't save between restarts

« Reply #8 posted: Jun 22, 2016, 01:50 PM »
No, wasteland does not require mods. Just read the IMPORTANT.TXT in the github repository i linked.

When I move the battleye files the console responds with

"15:36:31 BattlEye initialization failed"
"Server creation failed : 2302"

Re: extDB doesn't save between restarts

« Reply #9 posted: Jun 22, 2016, 02:12 PM »
When I move the battleye files the console responds with

"15:36:31 BattlEye initialization failed"
"Server creation failed : 2302"

Nevermind I think I got it working I just noticed this message:

"extDB2 NOT FOUND! Make sure extDB2.dll (Windows) or extDB2.so (Linux) and extdb-conf.ini are in the same directory as arma3server, and that you are using the -filePatching parameter"

BUT I have the extDB2.so file and the filePatching parameter, maybe badly formatted launch parameters ?

I am also getting errors that the the A3Wasteland_settings sql files are missing  I only have main_config.sqf but you only need that one with extDB right ?

Also its save to remove all the .dll files right ?

Re: extDB doesn't save between restarts

« Reply #10 posted: Jun 22, 2016, 02:28 PM »
Entire console log the last few lines keep repeating normal behavior right ?

http://pastebin.com/R7XX5DR7
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2489

Re: extDB doesn't save between restarts

« Reply #11 posted: Jun 22, 2016, 04:47 PM »
It's not the console log that is needed, the crucial information is in the RPT log.
or post your start.sh script.

Re: extDB doesn't save between restarts

« Reply #12 posted: Jun 22, 2016, 05:58 PM »
It's not the console log that is needed, the crucial information is in the RPT log.
or post your start.sh script.

start.sh looks like following:
./arma3server -config=./serverconfig/config.cfg -filePatching -world=empty -BEpath=/home/a3server/server/BattlEye

Maybe bad formatting ? Kind of new to the whole linux/arma scene.

I cant find the RPT log where is it saved I have no idea I googled some stuff but I could only find people saying
linux doesn't provide a RPT log. I found a method where you would specify the location in the launch script but in my case it broke the script.
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2489

Re: extDB doesn't save between restarts

« Reply #13 posted: Jun 22, 2016, 06:05 PM »
maybe try this:

Code: [Select]
./arma3server "-config=serverconfig/config.cfg" "-BEpath=/home/a3server/server/BattlEye" -filePatching
linux is a bit touchy with startup params, adding double quotes ensure the longer ones are interpreted correctly

Re: extDB doesn't save between restarts

« Reply #14 posted: Jun 22, 2016, 06:10 PM »
maybe try this:

Code: [Select]
./arma3server "-config=serverconfig/config.cfg" "-BEpath=/home/a3server/server/BattlEye" -filePatching
linux is a bit touchy with startup params, adding double quotes ensure the longer ones are interpreted correctly

Still gives the message saying
Code: [Select]
"[INFO] ███ extDB2 NOT FOUND! Make sure extDB2.dll (Windows) or extDB2.so (Linux) and extdb-conf.ini are in the same directory as arma3server, and that you are using the -filePatching parameter"