extDB beta

Re: extDB beta

« Reply #75 posted: Dec 27, 2014, 06:53 PM »
Just install vcredist_x86.exe
Link @ http://www.microsoft.com/en-ie/download/details.aspx?id=40784

All new extDB are built using VS2013, only the old ones are built using VS2010.

Re: extDB beta

« Reply #76 posted: Dec 27, 2014, 07:37 PM »
Just install vcredist_x86.exe
Link @ http://www.microsoft.com/en-ie/download/details.aspx?id=40784

All new extDB are built using VS2013, only the old ones are built using VS2010.

Thanks for all help! It is working now!
You saved my day!  :)

Code: [Select]
"[extDB] Startup..."
"[extDB] Connected to database"
"[extDB] Initialized DB_CUSTOM_V3 protocol"
"[extDB] Initialized MISC protocol"
"[extDB] Environment setup..."
"[extDB] Locked"
"Player connected: [DADS] Ancientevil_one (76561197970146381)"
  • Offline DRACO
  • Fresh Spawn
  • *
  • Posts: 19

Re: extDB beta

« Reply #77 posted: Jan 07, 2015, 01:25 AM »
I am trying to run this on MySQL server, but even when I follow the instructions, it keeps saying 'access denied' to a3wasteland database. Please help :)

Re: extDB beta

« Reply #78 posted: Jan 07, 2015, 05:28 AM »
I am trying to run this on MySQL server, but even when I follow the instructions, it keeps saying 'access denied' to a3wasteland database. Please help :)

You didn't grant the user mention enough privileges, double check those. If are certain that's not it try running it as root to verify.
  • Offline DRACO
  • Fresh Spawn
  • *
  • Posts: 19

Re: extDB beta

« Reply #79 posted: Jan 09, 2015, 02:04 PM »
Finally got it working :) Now the only issue is that it doesn't save the player exactly where you press ESC to save, it will put you in one of your previously visited locations.

Re: extDB beta

« Reply #80 posted: Jan 16, 2015, 12:15 AM »
Hi,

I need help.
I have a problem on my A3 Dedicated Ubuntu Server with extDB & A3wasteland Altis.

console :
Code: [Select]
2015/01/15, 23:53:28 "[extDB] Startup..."
2015/01/15, 23:53:28 "[extDB] ### Database error! [0,"No Config Option Found"]"
2015/01/15, 23:53:28 "[extDB] ### ERROR - Startup aborted"

Logfile:
Code: [Select]
[23:53:28 +01:00] [Thread 1658902851] extDB: Found extdb-conf.ini
...
[23:53:28 +01:00] [Thread 1658902851] extDB: No Config Option Found: a3wasteland

main_config.sqf:
Code: [Select]
A3W_savingMethod = "extDB";
...
A3W_extDB_ConfigName = "a3wasteland";
A3W_extDB_IniName = "a3wasteland";

extdb-conf.ini:
Code: [Select]
[Database2]
Type = MySQL
Name = a3wasteland

Username = a3wasteland
Password = xxxx
IP = 127.0.0.1
Port = 3306

Mysql :
Code: [Select]
DB : a3wasteland
User : a3wasteland
IP : localhost

I have :
A3W_extDB_pack.zip
A3Wasteland_v1.1.Altis.pbo

Do you have a solution ?

Thank you ;)
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2326

Re: extDB beta

« Reply #81 posted: Jan 16, 2015, 12:48 AM »
It's not [Database2], it's [A3W], and also, A3W_extDB_ConfigName = "A3W";

Obviously, you used the default extdb-conf.ini from Torndeco's repo and not the one provided in the A3W extDB pack.

Re: extDB beta

« Reply #82 posted: Jan 16, 2015, 01:06 AM »
It's not [Database2], it's [A3W], and also, A3W_extDB_ConfigName = "A3W";

Obviously, you used the default extdb-conf.ini from Torndeco's repo and not the one provided in the A3W extDB pack.

It's work !

Thank you ;)

Re: extDB beta

« Reply #83 posted: Jan 16, 2015, 11:21 PM »
This new version 1.1 extDB is working with stratis ?
  • Offline rocco
  • Fresh Spawn
  • *
  • Posts: 2

Re: extDB beta

« Reply #84 posted: Jan 16, 2015, 11:31 PM »
This new version 1.1 extDB is working with stratis ?

I tried, but I can not confirm it is working, because my Arma3 server get segmentation fault error with A3W v1.1 and extDB and crash.
Altis map works better with v1.1, still crash but not offen.

I plan to get all error messages and show to dev team.

Re: extDB beta

« Reply #85 posted: Jan 16, 2015, 11:46 PM »
I tried, but I can not confirm it is working, because my Arma3 server get segmentation fault error with A3W v1.1 and extDB and crash.
Altis map works better with v1.1, still crash but not offen.

I plan to get all error messages and show to dev team.

Yes, 1.1 works on both Stratis and Altis
  • Offline Nook
  • Fresh Spawn
  • *
  • Posts: 4

Re: extDB beta

« Reply #86 posted: Sep 06, 2017, 08:50 AM »
Hello all
I have an issues with the beta extDB3 not saving player ATM money. I have tested the parking garages, all player inventory, and money on player it all works just not the ATM account not saving. i have check the A3Wasteland_settings for player ATM saves, its enable.  Server log show its loading but [0,""Error Unknow Protocla""]"  unsure what is error is
See RPT log

2017/09/05, 23:32:50 "############################# Wasteland5 #############################"
2017/09/05, 23:32:50 "WASTELAND SERVER - Initializing Server"
2017/09/05, 23:32:50 Warning Message: Script \A3Wasteland_settings\antihack\payload.sqf not found
2017/09/05, 23:32:50 "ANTI-HACK: External payload unavailable, using internal payload"
2017/09/05, 23:32:50 Weather was forced to change
2017/09/05, 23:32:50 "ANTI-HACK: Started."
2017/09/05, 23:32:50 "WASTELAND SERVER - Initializing Server Vars"
2017/09/05, 23:32:50 "WASTELAND SERVER - Initializing Server Compile"
2017/09/05, 23:32:50 "WASTELAND SERVER - Initializing Server Relations"
2017/09/05, 23:32:50 "WASTELAND SERVER - Server Compile Finished"
2017/09/05, 23:32:50 "[INFO] extDB3 v1.028 extension loaded"
2017/09/05, 23:32:50 "[extDB3] Startup..."
2017/09/05, 23:32:50 "[extDB3] Initialized SQL_CUSTOM protocol"
2017/09/05, 23:32:50 "[extDB3] ███ MISC Protocol error! [0,""Error Unknown Protocol""]"
2017/09/05, 23:32:50 "[extDB3] Environment setup..."
2017/09/05, 23:32:50 "[extDB3] Locked"
2017/09/05, 23:32:50 "Loading storage functions ..."
2017/09/05, 23:32:50 "Setting up storage boxes ... "
2017/09/05, 23:32:50 "Loading parking misc functions"
2017/09/05, 23:32:50 "Loading parking misc functions complete"
2017/09/05, 23:32:50 "Loading list simple menu functions ... "
2017/09/05, 23:32:50 "Loading list simple menu functions complete"
2017/09/05, 23:32:50 "Loading parking interact functions ..."
2017/09/05, 23:32:50 "Loading parking interact functions complete"
2017/09/05, 23:32:50 "No storage in La Riviere"
2017/09/05, 23:32:51 "Loading parking saving functions ..."
2017/09/05, 23:32:51 "Loading parking saving functions complete"
2017/09/05, 23:32:51 "Loading parking functions ..."
2017/09/05, 23:32:51 "Setting up parking terminals ... "
2017/09/05, 23:32:51 "[extDB3] Startup complete!"
2017/09/05, 23:32:51 "[INFO] A3W playerSaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W baseSaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W vehicleSaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W boxSaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W staticWeaponSaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W warchestSaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W warchestMoneySaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W spawnBeaconSaving = ON"
2017/09/05, 23:32:51 "[INFO] A3W timeSaving = OFF"
2017/09/05, 23:32:51 "[INFO] A3W weatherSaving = OFF"
2017/09/05, 23:32:51 "[INFO] A3W hcObjSaving = OFF"
  • Offline JoSchaap
  • Developer
  • Mercenary
  • ******
  • Posts: 479
  • Had a life.. Got a modem.. (~1996)

Re: extDB beta

« Reply #87 posted: Sep 07, 2017, 09:41 PM »
please create a seperate topic in the appropriate subforum to keep things abit organized here.