got this in my rpt

got this in my rpt

« posted: Jun 08, 2015, 06:11 PM »
I found this in my RPT file. The general store does not have any items in it besides backpacks, headgear and uniforms.

} forEach call customPlayerItems;
};
} forEach call mf_>
10:47:44   Error position: <customPlayerItems;
};
} forEach call mf_>
10:47:44   Error Undefined variable in expression: customplayeritems
10:47:44 File mpmissions\__CUR_MP.Altis\client\systems\generalStore\getInventory.sqf, line 40
10:47:44 Error in expression <dex, _x select 1];
};
};
} forEach call customPlayerItems;
};
} forEach call mf_>
10:47:44   Error position: <customPlayerItems;
};
} forEach call mf_>
10:47:44   Error Undefined variable in expression: customplayeritems
10:47:44 File mpmissions\__CUR_MP.Altis\client\systems\generalStore\getInventory.sqf, line 40
10:47:44 Error in expression <= "CfgWeapons" };
};
};
} forEach (call _x)
} forEach [accessoriesArray, genItem>
10:47:44   Error position: <_x)
} forEach [accessoriesArray, genItem>
10:47:44   Error Undefined variable in expression: _x
10:47:44 File mpmissions\__CUR_MP.Altis\client\functions\getItemInfo.sqf, line 62
10:47:44 Error in expression < (call _x)
} forEach [accessoriesArray, genItemArray];
};

if (isNil "_itemEntry>
10:47:44   Error position: <genItemArray];
};

if (isNil "_itemEntry>
10:47:44   Error Undefined variable in expression: genitemarray
10:47:44 File mpmissions\__CUR_MP.Altis\client\functions\getItemInfo.sqf, line 63
10:47:44 Error in expression <Cfg = "CfgVehicles";
};
} forEach (call _x);
} forEach [backpackArray, genObject>
10:47:44   Error position: <_x);
} forEach [backpackArray, genObject>
10:47:44   Error Undefined variable in expression: _x
10:47:44 File mpmissions\__CUR_MP.Altis\client\functions\getItemInfo.sqf, line 92
10:47:44 Error in expression <Cfg = "CfgVehicles";
};
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2489

Re: got this in my rpt

« Reply #1 posted: Jun 08, 2015, 10:19 PM »
Means your storeConfig.sqf has a syntax error somewhere. Find the first error in your log, and fix it.

Re: got this in my rpt

« Reply #2 posted: Jun 08, 2015, 11:25 PM »
Means your storeConfig.sqf has a syntax error somewhere. Find the first error in your log, and fix it.

I think I found it. I had added a type of parachute and had forgotten to move the comma from the end of it to the end of the previous line to signal the end of the array.