battleye initialization failed.

  • Offline Violt
  • Geared Up
  • **
  • Posts: 38

battleye initialization failed.

« posted: Dec 28, 2017, 12:14 AM »
Everytime a player connects my server it says "battleye initialization failed"
On my Server console i see the player connecting and then connected to BE Master and after that the player is disconnected.

This is my RPT File

Code: [Select]
=====================================================================
== F:\Arma3Server\arma3server_x64.exe
== "arma3server_x64.exe"  -maxMem=5550 -port=2302 "-config=Admin\config.cfg" "-cfg=Admin\basic.cfg" "-profiles=Admin" -name=Admin -filePatching -netlog -pid=pid.log -ranking=ranking.log "-mod=extDB" -enableHT -autoInit

Original output filename: Arma3Retail_Server_x64
Exe timestamp: 2017/12/13 17:38:04
Current time:  2017/12/28 00:09:10

Type: Public
Build: Stable
Version: 1.80.143869

Allocator: F:\Arma3Server\Dll\tbb4malloc_bi_x64.dll [2017.0.0.0] [2017.0.0.0]
PhysMem: 7.9 GiB, VirtMem : 8192 GiB, AvailPhys : 5.2 GiB, AvailVirt : 8192 GiB, AvailPage : 36 GiB
=====================================================================





Connected to Steam servers
Wrong init state
c:\w\stable\futura\lib\network\networkserver.cpp NetworkServer::OnClientStateChanged:NOT IMPLEMENTED - briefing!
 Mission id: e8615dea79bb364a0b8bbc4f8036db6359c82e04
Land_PipeFence_01_m_gate_v2_closed_F: door_1_locked_rot - unknown animation source door_1_locked_source
Land_PipeFence_01_m_gate_v2_closed_F: door_2_locked_rot - unknown animation source door_2_locked_source
Attempt to override final function - bis_fnc_storeparamsvalues_data
Attempt to override final function - a3w_fnc_getteammarkercolor
"############################# ArmA3_Wasteland #############################"
"WASTELAND SERVER - Initializing Server"
Strange convex component202 in a3\structures_f\households\house_small01\d_house_small_01_v1_f.p3d:geometryView
Strange convex component203 in a3\structures_f\households\house_small01\d_house_small_01_v1_f.p3d:geometryView
Weather was forced to change
Warning Message: Script \A3Wasteland_settings\antihack\payload.sqf not found
"ANTI-HACK: External payload unavailable, using internal payload"
"ANTI-HACK: Started."
Warning Message: Script \A3Wasteland_settings\init.sqf not found
Warning Message: Script \A3Wasteland_settings\admins.sqf not found
"WASTELAND SERVER - Initializing Server Vars"
"WASTELAND SERVER - Initializing Server Compile"
"WASTELAND SERVER - Initializing Server Relations"
Warning Message: Script \A3Wasteland_settings\serverRules.sqf not found
"WASTELAND SERVER - Server Compile Finished"
Warning Message: Script \A3Wasteland_settings\main_config.sqf not found
"[WARNING] A3W configuration file '\A3Wasteland_settings\main_config.sqf' was not found. Using default settings!"
"[WARNING] For more information go to http://forums.a3wasteland.com/"
"[INFO] ### Saving method = profileNamespace"
CallExtension 'iniDB' could not be found
"[INFO] A3W playerSaving = ON"
"[INFO] A3W baseSaving = ON"
"[INFO] A3W vehicleSaving = ON"
"[INFO] A3W boxSaving = ON"
"[INFO] A3W staticWeaponSaving = ON"
"[INFO] A3W warchestSaving = ON"
"[INFO] A3W warchestMoneySaving = ON"
"[INFO] A3W spawnBeaconSaving = ON"
"[INFO] A3W timeSaving = ON"
"[INFO] A3W weatherSaving = ON"
"[INFO] A3W hcObjSaving = OFF"
"WASTELAND SERVER - Initializing Server Spawning"
"Loading storage functions ..."
"Setting up storage boxes ... "
"parking only compatible with extDB and sock, aborting setup."
Attempt to override final function - fn_getvehiclevars
Attempt to override final function - fn_preprocesssaveddata
Attempt to override final function - fn_restoresavedvehicle
"No storage in La Rivière"
Weather was forced to change
"Creating territory capture trigger for 'TERRITORY_AID_STATION'"
"Creating territory capture trigger for 'TERRITORY_AIRPORT_NORTH'"
"Creating territory capture trigger for 'TERRITORY_AIRPORT_SOUTH'"
"Creating territory capture trigger for 'TERRITORY_AIRPORT_TERMINAL'"
"A3Wasteland - world persistence loaded 0 objects from profileNamespace"
"A3Wasteland - world persistence loaded 0 vehicles from profileNamespace"
"Creating territory capture trigger for 'TERRITORY_CANCON_PENINSULA'"
"Creating territory capture trigger for 'TERRITORY_BUNKER'"
"Creating territory capture trigger for 'TERRITORY_CHAPEL'"
"Creating Storage at: Cancon ([5448.83,2824.6,43.4993])"
"A3Wasteland - world persistence loaded 0 mines from profileNamespace"
"Creating territory capture trigger for 'TERRITORY_CONSTRUCTION'"
"Creating territory capture trigger for 'TERRITORY_COVE'"
"Creating territory capture trigger for 'TERRITORY_GAS_STATION'"
"Creating territory capture trigger for 'TERRITORY_MANSION'"
"Creating territory capture trigger for 'TERRITORY_MILITARY_BASE'"
"No storage in Chapoi"
"Creating territory capture trigger for 'TERRITORY_OLD_MILITARY_BASE_EAST'"
"No storage in Sainte Marie"
"Creating territory capture trigger for 'TERRITORY_OLD_MILITARY_BASE_WEST'"
"Creating territory capture trigger for 'TERRITORY_PEGASUS_AIRFIELD'"
"Creating territory capture trigger for 'TERRITORY_SUBSTATION'"
"Creating territory capture trigger for 'TERRITORY_UN_COMMAND'"
"Creating territory capture trigger for 'TERRITORY_UN_OUTPOST'"
"Creating territory capture trigger for 'TERRITORY_AIRCRAFT_CARRIER'"
"WARNING: No config_territory_markers definition for marker 'TERRITORY_RADIO_STATION'. Deleting it!"
"Creating territory capture trigger for 'TERRITORY_FORTRESS_ISLAND'"
"Creating Storage at: La Pessagne ([3237.92,6275.4,225.299])"
"No storage in Vigny"
Duplicate HitPoint name 'HitTurret' in 'B_Heli_Light_01_F'
Duplicate HitPoint name 'HitGun' in 'B_Heli_Light_01_F'
Duplicate HitPoint name 'HitTurret' in 'B_Heli_Light_01_F'
Duplicate HitPoint name 'HitGun' in 'B_Heli_Light_01_F'
Duplicate HitPoint name 'HitTurret' in 'B_Heli_Light_01_F'
Duplicate HitPoint name 'HitGun' in 'B_Heli_Light_01_F'
Duplicate HitPoint name 'HitTurret' in 'B_Heli_Light_01_F'
Duplicate HitPoint name 'HitGun' in 'B_Heli_Light_01_F'
"No storage in Le Port"
"Loading vehicle misc functions ..."
"Loading vehicle misc functions complete"
"No storage in Arudy"
"Loading vector functions ... "
"Loading vector functions complete"
"No storage in Goisse"
"Loading vehicle actions functions ..."
"Loading vehicle actions functions complete"
"No storage in Houdan"
"No storage in Dourdan"
"Creating Storage at: Larche ([5969.12,8587.9,125.105])"
Land_NetFence_02_m_gate_v1_closed_F: door_1_locked_rot - unknown animation source door_1_locked_source
"Creating Storage at: La Trinité ([7231.64,7871.45,167.275])"
"Creating Storage at: Saint Louis ([7108.2,8890.2,104.307])"
"No storage in Moray"
"Creating Storage at: Lolisse ([5444.14,11370.8,39.6442])"
"No storage in Airport"
"Storage boxes setup complete"
"Loading storage functions complete"
"WASTELAND SERVER - 24 Static helis Spawned"
Duplicate HitPoint name 'HitTurret' in 'C_Offroad_01_F'
Duplicate HitPoint name 'HitGun' in 'C_Offroad_01_F'
Duplicate HitPoint name 'HitTurret' in 'C_Offroad_01_F'
Duplicate HitPoint name 'HitGun' in 'C_Offroad_01_F'
Duplicate HitPoint name 'HitTurret' in 'C_Offroad_01_F'
Duplicate HitPoint name 'HitGun' in 'C_Offroad_01_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitGun' in 'C_Van_01_transport_F'
Duplicate HitPoint name 'HitTurret' in 'I_G_Offroad_01_F'
Duplicate HitPoint name 'HitGun' in 'I_G_Offroad_01_F'
Duplicate HitPoint name 'HitTurret' in 'I_G_Offroad_01_F'
Duplicate HitPoint name 'HitGun' in 'I_G_Offroad_01_F'
Duplicate HitPoint name 'HitTurret' in 'I_G_Offroad_01_F'
Duplicate HitPoint name 'HitGun' in 'I_G_Offroad_01_F'
BEServer: cannot find channel #1831987243, users.card=0
BEServer: cannot find channel #1831987243, users.card=0
BEServer: cannot find channel #1831987243, users.card=0
"WASTELAND - Vehicle spawning completed - 201 town vehicles spawned in 15.275s"
"WASTELAND SERVER - 0 Planes Spawned"
Duplicate HitPoint name 'HitTurret' in 'I_Boat_Armed_01_minigun_F'
Duplicate HitPoint name 'HitGun' in 'I_Boat_Armed_01_minigun_F'
"WASTELAND SERVER - 18 Boats Spawned"
BEServer: cannot find channel #1831987243, users.card=0
"WASTELAND - Object spawning completed - 237 objects spawned"
"[INFO] A3W territory capturing is ENABLED"
"WASTELAND SERVER - Initializing Missions"
"WASTELAND SERVER - Started Main Mission Controller"
"WASTELAND SERVER - Main Mission waiting to run: mission_Convoy"
"A3W - 0 baseparts and objects have been saved with profileNamespace"
BEServer::finishDestroyPlayer(1831987243): users.get failed
"A3W - profileNamespace saved"
"WASTELAND SERVER - Started Money Mission Controller"
"WASTELAND SERVER - Money Mission waiting to run: mission_SunkenTreasure"
"WASTELAND SERVER - Started Side Mission Controller"
"WASTELAND SERVER - Side Mission waiting to run: mission_MiniConvoy"
"WASTELAND SERVER - Started Main Mission 2 Controller"
"WASTELAND SERVER - Main Mission 2 waiting to run: mission_LightArmVeh"
"WASTELAND SERVER - Started Money Mission 2 Controller"
"WASTELAND SERVER - Money Mission 2 waiting to run: mission_MoneyShipment"
"A3W - 0 vehicles have been saved with profileNamespace"
"A3W - profileNamespace saved"
"WASTELAND SERVER - Started Side Mission 2 Controller"
"WASTELAND SERVER - Side Mission 2 waiting to run: mission_Outpost"
"A3W - 0 mines have been saved with profileNamespace"
"A3W - profileNamespace saved"
"A3W - 0 baseparts and objects have been saved with profileNamespace"
"A3W - profileNamespace saved"
"A3W - 0 vehicles have been saved with profileNamespace"
"A3W - profileNamespace saved"
"A3W - 0 mines have been saved with profileNamespace"
"A3W - profileNamespace saved"
"A3W - 0 baseparts and objects have been saved with profileNamespace"
"A3W - profileNamespace saved"
"A3W - 0 vehicles have been saved with profileNamespace"
"A3W - profileNamespace saved"
"A3W - 0 mines have been saved with profileNamespace"
"A3W - profileNamespace saved"
"A3W - 0 baseparts and objects have been saved with profileNamespace"
"A3W - profileNamespace saved"

Can someone help me with this problem?

Re: battleye initialization failed.

« Reply #1 posted: Dec 28, 2017, 08:28 PM »
Where is the battleye path in the start up parameter?

=====================================================================
== C:\ServerFolder\arma3server_x64.exe
== arma3server_x64.exe  -serverMod=@extDB3;@infiSTAR_A3 -name=A3W -config=config\config.cfg -cfg=config\basic.cfg -profiles=profile -filePatching -autoinit -enableHT -malloc=tbbmalloc_x64 -bepath=C:\ServerFolder\battleye
  • Offline Violt
  • Geared Up
  • **
  • Posts: 38

Re: battleye initialization failed.

« Reply #2 posted: Dec 29, 2017, 01:06 AM »
Where is the battleye path in the start up parameter?

=====================================================================
== C:\ServerFolder\arma3server_x64.exe
== arma3server_x64.exe  -serverMod=@extDB3;@infiSTAR_A3 -name=A3W -config=config\config.cfg -cfg=config\basic.cfg -profiles=profile -filePatching -autoinit -enableHT -malloc=tbbmalloc_x64 -bepath=C:\ServerFolder\battleye
I added it. wasn't the problem.
Still have Battleye initialization failed.
I really have no idea how to fix this.

Re: battleye initialization failed.

« Reply #3 posted: Jan 03, 2018, 01:58 PM »
I added it. wasn't the problem.
Still have Battleye initialization failed.
I really have no idea how to fix this.

Config.cfg
BattlEye = 1;
  • Offline Violt
  • Geared Up
  • **
  • Posts: 38

Re: battleye initialization failed.

« Reply #4 posted: Jan 05, 2018, 02:35 PM »
Fixed the problem! it was a port problem. the RCon was to close to gameport and the Battleye port.

I want to thank you for the help!