AI_Spawn

AI_Spawn

« posted: Jan 21, 2015, 08:18 AM »
This is my first post and I am not quite sure where to post so here's to hoping i'm posting in the right category.

I was looking through IvanMMM version of arma
https://github.com/IvanMMM/ArmA3_Wasteland.Altis

and was wondering how to get whats located in AI_Spawn to work. I notice there are lots of patrols and features in the folder under addons.  I have just about everything else to work correctly but the ai_spawn has me stumped.  Having roming ai and what not would be a great addition to any server.

 Any help would be great.

Thank you!

Re: AI_Spawn

« Reply #1 posted: Jan 21, 2015, 11:08 AM »
Well, my players like it, but it has another side. Huge amount of AI heavily increases CPU usage for server, so think twice before doing it.

Re: AI_Spawn

« Reply #2 posted: Jan 21, 2015, 08:12 PM »
I didnt think of it that way.  I will have to test and see if my server can handle the extra load.  Still not sure how to get it to work, I cant find where to call the scripts in the folder from.  Again I am very new to modding so just looking for a little guidance.

Thanks!
  • Offline CREAMPIE
  • Armaholic
  • Veteran
  • ******
  • Posts: 1085
  • ^_^;;

Re: AI_Spawn

« Reply #3 posted: Jan 21, 2015, 10:05 PM »
Badvolt - I take it that server isn't running something like Inidb :P i tried firing up the mission file and it just kicks me out saying mission failed :P


- from the grassy knoll -

Re: AI_Spawn

« Reply #4 posted: Jan 22, 2015, 09:28 AM »
This feature will work in any branch. If you want to try it - just copy AI_Spawn folder to addons and "\territory\server\monitorTerritories.sqf" && "\territory\server\createCaptureTriggers.sqf"
  • Offline LouD
  • Silent but deadly ;)
  • Moderator
  • Veteran
  • ******
  • Posts: 1415

Re: AI_Spawn

« Reply #5 posted: Jan 22, 2015, 09:54 AM »
What kind of server hardware are you running BadVolt?
And how many AI are spawned in?

Re: AI_Spawn

« Reply #6 posted: Jan 22, 2015, 12:05 PM »
Can't say exact value of AI, but it's more than 100 (missions + guards).
But I'm using ZBE_Caching addon + performance branch.

Intel Xeon E3-1230v3 @3.30GHz
16GB Ram

Re: AI_Spawn

« Reply #7 posted: Feb 16, 2015, 10:13 PM »
Hey all,

So I tried this - I added the AI_Spawn pack into the /addons folder, then copied the two files from the github repo above, replacing my old ones...

No joy :( Nothing seems to spawn.

I can't see any errors in RPT either - anyone have ideas?
  • Offline spec0ps
  • Geared Up
  • **
  • Posts: 30
  • theagc.com.au

Re: AI_Spawn

« Reply #8 posted: Feb 18, 2015, 04:40 PM »
I did try moving just the folders you said and it also did not work. The territories were there & capturable but were not marked on the map.

I managed to get it working by moving over the whole territory folder, only thing is every single territory is displayed. It also spawns a heap of mines for independent as opposed to helidropping in friendly ai as it does for opfor & blufor.

I tried editing this out and making it spawn resistance group via helidrop instead and couldn't get it working has anyone else managed to get it working?

Re: AI_Spawn

« Reply #9 posted: Feb 18, 2015, 08:03 PM »
I did try moving just the folders you said and it also did not work. The territories were there & capturable but were not marked on the map.

I managed to get it working by moving over the whole territory folder, only thing is every single territory is displayed. It also spawns a heap of mines for independent as opposed to helidropping in friendly ai as it does for opfor & blufor.

I tried editing this out and making it spawn resistance group via helidrop instead and couldn't get it working has anyone else managed to get it working?

Have a look here. I have it working great on my server, and disabled the mines as they were making the players not sooo happy. When the coder put in there "We need a LOT of mines." they were not kidding. But have a look at lines 300 to 326 where I disabled them. Basically I made it so that Blufor and Opfor get suppport after capture and Independents get no support as hey they are independent.

https://github.com/Spackler/ArmA3_WastelandPublic.Altis/blob/d73b5ec77530966fb91377a4593badea44ebf403/territory/server/monitorTerritories.sqf

Also take a look at line 44 here
https://github.com/Spackler/ArmA3_WastelandPublic.Altis/blob/d73b5ec77530966fb91377a4593badea44ebf403/territory/server/createCaptureTriggers.sqf



Re: AI_Spawn

« Reply #10 posted: Feb 18, 2015, 08:59 PM »
Spackler....  How did you get them to run server side? How did you get them to execute?

Re: AI_Spawn

« Reply #11 posted: Feb 18, 2015, 11:24 PM »
Spackler....  How did you get them to run server side? How did you get them to execute?

Those two files cause them to spawn in all the capture points in the map. Number depends on size of capture point.

Re: AI_Spawn

« Reply #12 posted: Feb 18, 2015, 11:31 PM »
but does the init file in main pbo get a line added for them to execute? I guess that's where Im lost and their location of where they should be placed.

Re: AI_Spawn

« Reply #13 posted: Feb 19, 2015, 01:12 AM »
Add the AI_Spawn folder to your addons. Then update those lines of code in your files to match yours. Then once the server starts it will auto add AI to all capture points on the map.

Re: AI_Spawn

« Reply #14 posted: Jun 13, 2015, 10:30 PM »
can this be done using ALiVE to handle the AI patrols and caching? should drastically reduce server load