Battle Eye filter issues

  • Offline Mokey
  • Fractured Wasteland
  • Elite
  • ******
  • Posts: 606
  • Https://Fractured-Gaming.com

Battle Eye filter issues

« posted: Apr 04, 2015, 04:40 AM »
I have put battleeye filters on my server (linux) and they are not showing up in logs...any takers?

I have the directories for both arma 3 and arma 3 other profiles set up correctly

I have also the Battleye.so file and the filters.... still no logs are being created.
Posts once, edits post 40 times in 60 seconds. STUPID FAT FINGERS!

Re: Battle Eye filter issues

« Reply #1 posted: Apr 06, 2015, 03:11 AM »
Same problem here :S

Also the filters are not being apllied , i has been dealing with a lot of hackers in this days.

Any idea ??
  • Offline Mokey
  • Fractured Wasteland
  • Elite
  • ******
  • Posts: 606
  • Https://Fractured-Gaming.com

Re: Battle Eye filter issues

« Reply #2 posted: Apr 06, 2015, 06:49 AM »
here's what we got so far.. I think we got it.

1.)when in Linux go to you arma 3 user directory
2.) Add -name=arma3server to your startup parameters
Code: [Select]
-name=arma3server 3.) Go back to your main directory. Show all hidden files. See if you can see a folder called .local
    If there isn't on make the Directory like this .
Code: [Select]
mkdir -p .local/share/Arma\ 3 &
Code: [Select]
mkdir -p .local/share/Arma\ 3\ -\ Other\ Profiles/
4.) after that restart your server, new folders should appear in both
5.) that will get you your profile cfg
6.) we made all files in our server rewriteable that's up to you. we think it was a permissions issue
7.) Logs should start appearing in your Battleye folder upon hackers getting on.

Also make sure you have all Battleye filters in your battleye folder along with Battleye.so and not the Battleye.dll

Here are my current Parameters

Code: [Select]
fn_parms(){
parms="-name=arma3server -netlog -sock_host=${sockip} -sock_port=${sockport} -ip=${ip} -cfg=${networkcfgfullpath} -config=${servercfgfullpath} -BEPath=${bep} -mod=${mods}"
}

These are the variables the above parameters call for

Code: [Select]
# Directories
rootdir="$(cd "$(dirname "${BASH_SOURCE[0]}" )" && pwd )"
selfname="$(basename $0)"
lockselfname=".${servicename}.lock"
filesdir="${rootdir}/serverfiles"
systemdir="${filesdir}"
executabledir="${filesdir}"
executable="./arma3server"
servercfgdir="${systemdir}/cfg"
servercfg="${servicename}.server.cfg"
networkcfg="${servicename}.network.cfg"
servercfgfullpath="${servercfgdir}/${servercfg}"
networkcfgfullpath="${servercfgdir}/${networkcfg}"
backupdir="${rootdir}/backups"
bep="${filesdir}/battleye"
#socket params
sockip="127.0.0.1"
sockport="1337"

Ignore the Socket parameters thats for the database for couch DB
Posts once, edits post 40 times in 60 seconds. STUPID FAT FINGERS!

Re: Battle Eye filter issues

« Reply #3 posted: Apr 06, 2015, 06:36 PM »
Thx Monkey for the time ;)

I will try this today !.
  • Offline matias
  • Fresh Spawn
  • *
  • Posts: 12

Re: Battle Eye filter issues

« Reply #4 posted: Apr 07, 2015, 03:48 AM »
well , as ferik say . i check the files and ownership and rigths .
i start the game like this:
Code: [Select]
cd /home/steam/steamcmd/svrfiles/arma3srv/
nohup /home/steam/steamcmd/svrfiles/arma3srv/arma3server -cfg=/home/steam/steamcmd/svrfiles/arma3srv/parametros/basic.cfg -config=/home/steam/steamcmd/svrfiles/arma3srv/parametros/config.cfg -bepath=/home/steam/steamcmd/svrfiles/arma3srv/battleye -cpuCount=4 -exThreads=7 -mod=@inidbi\;A3Wasteland_settings -autoinit &

now i ll add the -name=Player on the startup lines.
i got the battleye updated and placed the folder on the following locations:
Code: [Select]
/home/steam/steamcmd/svrfiles/arma3srvorg/battleye
/home/steam/steamcmd/svrfiles/arma3srv/expansion/battleye
/home/steam/steamcmd/svrfiles/arma3srv/battleye
/home/steam/steamcmd/svrfiles/arma3srv/parametros/battleye
/home/steam/Steam/steamapps/downloading/233780/battleye
/home/steam/.local/share/Arma 3 - Other Profiles/Player/battleye

where it suppouse write logs doesnt do.

Code: [Select]
~/.local/share/Arma 3 - Other Profiles/Player/battleye$ ls -ltr
total 296
-rwxr-xr-x 1 steam steam     83 Apr  4 16:06 waypointStatement.txt
-rwxr-xr-x 1 steam steam     83 Apr  4 16:06 waypointCondition.txt
-rwxr-xr-x 1 steam steam    536 Apr  4 16:06 setVariable.txt
-rwxr-xr-x 1 steam steam    248 Apr  4 16:06 scripts.txt
-rwxr-xr-x 1 steam steam    205 Apr  4 16:06 remoteExec.txt
-rwxr-xr-x 1 steam steam    394 Apr  4 16:06 remoteControl.txt
-rwxr-xr-x 1 steam steam    340 Apr  4 16:06 publicVariableVal.txt
-rwxr-xr-x 1 steam steam   5183 Apr  4 16:06 publicVariable.txt
-rwxr-xr-x 1 steam steam     72 Apr  4 16:06 mpEventHandler.txt
-rwxr-xr-x 1 steam steam   1787 Apr  4 16:06 eula.txt
-rwxr-xr-x 1 steam steam     75 Apr  4 16:06 deleteVehicle.txt
-rwxr-xr-x 1 steam steam   1184 Apr  4 16:06 createVehicle.txt
-rwxr-xr-x 1 steam steam 244689 Apr  4 16:06 beserver.so
-rw-r--r-- 1 steam steam     83 Apr  4 16:06 beserver_active_10378855.cfg

but in the main instalation arma3srv/battleye do:
Code: [Select]
steam@ubuntu:~/steamcmd/svrfiles/arma3srv/battleye$ ls -ltr
total 336
-rwxr-xr-x 1 steam steam   1787 Jan 22 02:38 eula.txt
-rwxr-xr-x 1 steam steam 244689 Mar 30 21:24 beserver.so
-rw-r--r-- 1 steam steam     83 Apr  4 15:21 beserver_active_10378855.cfg
-rwxr-xr-x 1 steam steam    394 Apr  4 18:04 remoteControl.txt
-rwxr-xr-x 1 steam steam    340 Apr  4 18:04 publicVariableVal.txt
-rwxr-xr-x 1 steam steam     72 Apr  4 18:04 mpEventHandler.txt
-rwxr-xr-x 1 steam steam     75 Apr  4 18:04 deleteVehicle.txt
-rwxr-xr-x 1 steam steam   1184 Apr  4 18:04 createVehicle.txt
-rwxr-xr-x 1 steam steam     83 Apr  4 18:04 waypointStatement.txt
-rwxr-xr-x 1 steam steam     83 Apr  4 18:04 waypointCondition.txt
-rwxr-xr-x 1 steam steam    536 Apr  4 18:04 setVariable.txt
-rwxr-xr-x 1 steam steam    248 Apr  4 18:04 scripts.txt
-rwxr-xr-x 1 steam steam    205 Apr  4 18:04 remoteExec.txt
-rwxr-xr-x 1 steam steam   5183 Apr  4 18:04 publicVariable.txt
-rw-r--r-- 1 steam steam  34297 Apr  5 03:49 scripts.log
the interesting thing here its the scripts.txt generates the scripts.log. and writhe some shi... of teleports . the filter placed in the folder was provided by agentrev over github.
Code: [Select]
05.04.2015 03:49:12: G.Rider (190.30.112.89:2304) 0fd7927e934749398a05a05ce3c2260a - #3 "openMap [true, false];onMapSingleClick '_pos1 = [(_pos select 0), (_pos select 1), 0]; vehicle player setPos _pos1;hint format ["
05.04.2015 03:49:22: G.Rider (190.30.112.89:2304) 0fd7927e934749398a05a05ce3c2260a - #3 "leported to \n %2 \n by ThirtySix", name player, _pos1] onMapSingleClick "";openMap [false, false];"