A3W Not Running with ExtDB!

A3W Not Running with ExtDB!

« posted: Jun 27, 2015, 02:39 AM »
This is a section from my RTP file

Code: [Select]
2015/06/26, 18:00:36 "WASTELAND SERVER - Initializing Server"
2015/06/26, 18:00:37 "WASTELAND SERVER - Bounty System Main Loop Started"
2015/06/26, 18:00:37 "Loading vehicle misc functions ..."
2015/06/26, 18:00:37 "Loading vehicle misc functions complete"
2015/06/26, 18:00:38 "Loading vector functions ... "
2015/06/26, 18:00:38 "Loading vector functions complete"
2015/06/26, 18:00:38 "ANTI-HACK: Started."
2015/06/26, 18:00:38 "Loading vehicle actions functions ..."
2015/06/26, 18:00:38 "Loading vehicle actions functions complete"
2015/06/26, 18:00:38 "WASTELAND SERVER - Initializing Server Relations"
2015/06/26, 18:00:38 "WASTELAND SERVER - Initializing Server Compile"
2015/06/26, 18:00:38 "WASTELAND SERVER - Initializing Server Vars"
2015/06/26, 18:00:38 "WASTELAND SERVER - Server Compile Finished"
2015/06/26, 18:00:38 "[INFO] ### Checking extDB2 startup"
2015/06/26, 18:00:38 "[INFO] ### extDB2: pull version"
2015/06/26, 18:00:38 "[INFO] ### extDB2: check version"
2015/06/26, 18:00:38 "[INFO] ### A3W NOT running with extDB!"
2015/06/26, 18:00:38 "[INFO] ### Saving method = profileNamespace"
2015/06/26, 18:00:38 "[INFO] A3W playerSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W baseSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W vehicleSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W boxSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W staticWeaponSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W warchestSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W warchestMoneySaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W spawnBeaconSaving = ON"
2015/06/26, 18:00:41 "[INFO] A3W loot spawning is ENABLED"
2015/06/26, 18:00:41 "WASTELAND SERVER - Initializing Server Spawning"

when I look at my Sql is stays I have 4 connections to wastland, but it seem to not be working....btw I'm an SQL noob....so please dumb your answers down  :)

Re: A3W Not Running with ExtDB!

« Reply #1 posted: Jun 27, 2015, 03:55 AM »
This is a section from my RTP file

Code: [Select]
2015/06/26, 18:00:36 "WASTELAND SERVER - Initializing Server"
2015/06/26, 18:00:37 "WASTELAND SERVER - Bounty System Main Loop Started"
2015/06/26, 18:00:37 "Loading vehicle misc functions ..."
2015/06/26, 18:00:37 "Loading vehicle misc functions complete"
2015/06/26, 18:00:38 "Loading vector functions ... "
2015/06/26, 18:00:38 "Loading vector functions complete"
2015/06/26, 18:00:38 "ANTI-HACK: Started."
2015/06/26, 18:00:38 "Loading vehicle actions functions ..."
2015/06/26, 18:00:38 "Loading vehicle actions functions complete"
2015/06/26, 18:00:38 "WASTELAND SERVER - Initializing Server Relations"
2015/06/26, 18:00:38 "WASTELAND SERVER - Initializing Server Compile"
2015/06/26, 18:00:38 "WASTELAND SERVER - Initializing Server Vars"
2015/06/26, 18:00:38 "WASTELAND SERVER - Server Compile Finished"
2015/06/26, 18:00:38 "[INFO] ### Checking extDB2 startup"
2015/06/26, 18:00:38 "[INFO] ### extDB2: pull version"
2015/06/26, 18:00:38 "[INFO] ### extDB2: check version"
2015/06/26, 18:00:38 "[INFO] ### A3W NOT running with extDB!"
2015/06/26, 18:00:38 "[INFO] ### Saving method = profileNamespace"
2015/06/26, 18:00:38 "[INFO] A3W playerSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W baseSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W vehicleSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W boxSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W staticWeaponSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W warchestSaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W warchestMoneySaving = ON"
2015/06/26, 18:00:38 "[INFO] A3W spawnBeaconSaving = ON"
2015/06/26, 18:00:41 "[INFO] A3W loot spawning is ENABLED"
2015/06/26, 18:00:41 "WASTELAND SERVER - Initializing Server Spawning"

when I look at my Sql is stays I have 4 connections to wastland, but it seem to not be working....btw I'm an SQL noob....so please dumb your answers down  :)

It appears that your saving method is not set to ExtDB.

Re: A3W Not Running with ExtDB!

« Reply #2 posted: Jun 27, 2015, 04:50 AM »
here's my config

Code: [Select]
// Persistence settings
A3W_savingMethod = "extDB";        // Method used for saving data ("profile", "iniDB", "extDB")
A3W_playerSaving = 1;              // Save player data like position, health, inventory, etc. (0 = no, 1 = yes)
A3W_moneySaving = 1;               // If playerSaving = 1, save player money amount (0 = no, 1 = yes)
A3W_combatAbortDelay = 60;         // If playerSaving = 1, delay in seconds for which to disable abort and respawn buttons after firing or being shot (0 = none)
A3W_purchasedVehicleSaving = 1;    // Save vehicles purchased at vehicle stores between server restarts (0 = no, 1 = yes)
A3W_missionVehicleSaving = 1;      // Save vehicles captured from missions between server restarts (0 = no, 1 = yes)
A3W_baseSaving = 1;                // Save locked base parts between server restarts (0 = no, 1 = yes)
A3W_boxSaving = 1;                 // Save locked weapon crates and their contents between server restarts (0 = no, 1 = yes)
A3W_staticWeaponSaving = 1;        // Save locked static weapons and their magazines between server restarts (0 = no, 1 = yes)
A3W_warchestSaving = 1;            // Save warchest objects deployed by players between server restarts (0 = no, 1 = yes)
A3W_warchestMoneySaving = 1;       // Save warchest team money between server restarts (0 = no, 1 = yes)
A3W_spawnBeaconSaving = 1;         // Save spawn beacons between server restarts (0 = no, 1 = yes)
A3W_objectLifetime = 5*24;         // Maximum lifetime in hours for saved objects (baseparts, crates, etc. except vehicles) across server restarts (0 = no time limit)
A3W_vehicleLifetime = 0;           // Maximum lifetime in hours for saved vehicles across server restarts, regardless of usage (0 = no time limit)
A3W_vehicleMaxUnusedTime = 2*24;   // Maximum parking time in hours after which unused saved vehicles will be marked for deletion (0 = no time limit)
A3W_serverSavingInterval = 1*60;   // Interval in seconds between automatic vehicle & object saves; should be kept at 1 min for profileNamespace and iniDB, while for extDB it can be relaxed to 3-5 mins

// iniDB settings
PDB_PlayerFileID = "A3W_";         // Player savefile prefix (if you run multiple servers, keep it the same for all of them)
PDB_ObjectFileID = "A3W_";         // Object savefile prefix (if you run multiple servers, change it to a unique value for each server)

// extDB settings
A3W_extDB_ServerID = 1;            // Server ID to use in the database for the particular server running off this config file; if you have multiple servers, they all need different IDs
A3W_extDB_Environment = "normal";  // Value used to separate player & object data from multiple environments running on the same map (e.g. "normal", "hardcore", "dev", etc. can be whatever you want)
A3W_extDB_SaveUnlockedObjects = 1; // Save and restore unlocked baseparts that were locked at least once during their lifetime (0 = no, 1 = yes)
A3W_extDB_ConfigName = "A3W";      // Name of the connection config from extdb-conf.ini to be used (the one within [brackets])
A3W_extDB_IniName = "a3wasteland"; // Name of the INI file in extDB\db_custom to be used
A3W_extDB_Debug = 0;               // Log all queries to server RPT (0 = no, 1 = yes)
  • Offline Matt76
  • Mercenary
  • *****
  • Posts: 418
  • co founder of customcombatgaming.com

Re: A3W Not Running with ExtDB!

« Reply #3 posted: Jun 27, 2015, 09:32 AM »
I don't run extDB2 but maybe put that in your config?

Re: A3W Not Running with ExtDB!

« Reply #4 posted: Jun 28, 2015, 01:00 AM »
changed this extDB to extDB2 made come crazy errors and could not join the server
  • Offline Matt76
  • Mercenary
  • *****
  • Posts: 418
  • co founder of customcombatgaming.com

Re: A3W Not Running with ExtDB!

« Reply #5 posted: Jun 28, 2015, 01:27 AM »
Okay maybe not then  :-X

Have you set up your wasteland ini up correctly? The one in your route directory, that's where I'd start looking if you are saying the db is set up and running.

Re: A3W Not Running with ExtDB!

« Reply #6 posted: Jun 28, 2015, 06:34 AM »
thanks Matt, I'll give that a good once over.