Blackfish Vehicle Transport

Blackfish Vehicle Transport

« posted: Aug 03, 2016, 06:29 PM »
How would I enable the Blackfish in Wasteland so it can transport vehicles in Wasteland?

"V-44 X Blackfish (Vehicle Trans)", "B_T_VTOL_01_vehicle_F" &
"Y-32 Xi'an (Vehicle Trans)", "O_T_VTOL_02_vehicle_F"

It works in the Editor..You just pull up behind the Blackfish & a Xi'an and in the drop-down menu it gives you the ability to load vehicle into the Blackfish or Xi'an but while in Wasteland this is not so.

Any guidance is appreciated. I know its something simple..

Currently it doesn't work on Wasteland Altis nor Tanoa..

Re: Blackfish Vehicle Transport

« Reply #1 posted: Aug 04, 2016, 12:08 PM »
We have been able to load vehicles in Wasteland, Tanoa into the Blackfish, all be it, no large vehicles, and no more than one.

Haven't really bothered much with it, but you might want to look in:

addons\R3F_LOG\config.sqf

In the following section:

Code: [Select]
R3F_LOG_CFG_can_transport_cargo = R3F_LOG_CFG_can_transport_cargo +
[
// e.g. : ["MyTransporterClassName1", itsCapacity], ["MyTransporterClassName2", itsCapacity]
["Quadbike_01_base_F", 5],
["UGV_01_base_F", 10],
["Hatchback_01_base_F", 10],
["SUV_01_base_F", 20],
["Offroad_01_base_F", 130],
["Van_01_base_F", 40],
["MRAP_01_base_F", 20],
["MRAP_02_base_F", 20],
["MRAP_03_base_F", 20],
["B_Truck_01_box_F", 1500],
["Truck_F", 275],
["Wheeled_APC_F", 30],
["Tank_F", 130],
["Rubber_duck_base_F", 10],
["Boat_Civil_01_base_F", 10],
["Boat_Armed_01_base_F", 20],
["Heli_Light_01_base_F", 10],
["Heli_Light_02_base_F", 20],
["Heli_light_03_base_F", 20],
["Heli_Transport_01_base_F", 125],
["Heli_Transport_02_base_F", 130],
["Heli_Transport_03_base_F", 1150],
["Heli_Transport_04_base_F", 130],
["Heli_Attack_01_base_F", 10],
["Heli_Attack_02_base_F", 20],
["Land_Pod_Heli_Transport_04_box_F", 1300],
["Land_CargoBox_V1_F", 500],
["Land_Cargo20_yellow_F", 1000],
["Land_Cargo40_white_F", 2000],
["B_T_VTOL_01_infantry_F", 3000],
["B_T_VTOL_01_vehicle_F", 3000],    <-------- Blackfish Vehicle Transport.
["B_T_VTOL_01_armed_F", 3000],
["O_T_VTOL_02_vehicle_F", 3000],
["C_Offroad_02_unarmed_F", 1000],
["I_C_Offroad_02_unarmed_F", 1000],
["B_T_UAV_03_F", 5000],
["C_Plane_Civil_01_F", 500],
["C_Plane_Civil_01_Racing_F", 850],
["B_CTRG_LSV_01_light_F", 950],
["B_T_LSV_01_unarmed_F", 950],
["B_T_LSV_01_armed_F", 950],
["O_T_LSV_02_unarmed_F", 950],
["O_T_LSV_02_armed_F", 950],
["C_Scooter_Transport_01_F", 1000]

];

And make sure "["B_T_VTOL_01_vehicle_F", 3000]" is listed.

Hope this helps.

Regards

SpeedBirdNam

Re: Blackfish Vehicle Transport

« Reply #2 posted: Aug 04, 2016, 04:31 PM »
I looked in there and its NOT listed. If you don't mind me asking where did you get this from? I looked at that yesterday and was going to add it to there and didn't because I was not 100% sure but next time my gut feeling feels like that I will add it...
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2488

Re: Blackfish Vehicle Transport

« Reply #3 posted: Aug 04, 2016, 04:45 PM »
Arma's new "vehicle transport" feature has nothing to do with R3F. It does however work similarly to R3F airlifting and paradropping. It can be used with the Vehicle Transport variants of the VTOL aircraft. I don't know how to operate it outside the editor, and I do not plan to investigate, as R3F airlifting already fulfills the same function and is more flexible.

Re: Blackfish Vehicle Transport

« Reply #4 posted: Aug 04, 2016, 05:06 PM »
AgentRev its not a problem but that did fix the problem for me allowing "Load In" to show up in the Action Menu server side in game.

I looked at the playerActions.sqf last night and didn't notice anything out of the ordinary but your the one who can probably see it better than I can.
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2488

Re: Blackfish Vehicle Transport

« Reply #5 posted: Aug 04, 2016, 05:28 PM »
Official vehicle transport actions are from the game engine, they're not in the mission scripts. The green R3F actions are not related in any way.

Maybe look at this: https://community.bistudio.com/wiki/Arma_3_Vehicle_in_Vehicle_Transport

Re: Blackfish Vehicle Transport

« Reply #6 posted: Aug 04, 2016, 07:13 PM »
Hello.

I didn't add it myself, it was just there.

Apparently things were shaken up a bit again with the release of Apex.

Thanks for the headsup AgentRev.

Re: Blackfish Vehicle Transport

« Reply #7 posted: Aug 04, 2016, 07:20 PM »
Wouldn't this mean that somewhere in Wasteland that enableVehicleCargo is disabled or set to false? But this would have to be specifically set to this vehicle, or this vehicle class or globally somehow. Just brainstorming the reason why its being disabled in Wasteland somehow. I think its something very simple to be honest.

Re: Blackfish Vehicle Transport

« Reply #8 posted: Aug 04, 2016, 07:22 PM »
Official vehicle transport actions are from the game engine, they're not in the mission scripts. The green R3F actions are not related in any way.

Maybe look at this: https://community.bistudio.com/wiki/Arma_3_Vehicle_in_Vehicle_Transport
'


I understand this AgentRev as the Repair, Ammo and others works in Wasteland and they are from the game engine but can in fact be disabled accidentally. Yes or no? Just giving you food for thought..

Re: Blackfish Vehicle Transport

« Reply #9 posted: Aug 04, 2016, 08:24 PM »
We have been able to load vehicles in Wasteland, Tanoa into the Blackfish, all be it, no large vehicles, and no more than one.

Haven't really bothered much with it, but you might want to look in:

addons\R3F_LOG\config.sqf

In the following section:

Code: [Select]
R3F_LOG_CFG_can_transport_cargo = R3F_LOG_CFG_can_transport_cargo +
[
// e.g. : ["MyTransporterClassName1", itsCapacity], ["MyTransporterClassName2", itsCapacity]
["Quadbike_01_base_F", 5],
["UGV_01_base_F", 10],
["Hatchback_01_base_F", 10],
["SUV_01_base_F", 20],
["Offroad_01_base_F", 130],
["Van_01_base_F", 40],
["MRAP_01_base_F", 20],
["MRAP_02_base_F", 20],
["MRAP_03_base_F", 20],
["B_Truck_01_box_F", 1500],
["Truck_F", 275],
["Wheeled_APC_F", 30],
["Tank_F", 130],
["Rubber_duck_base_F", 10],
["Boat_Civil_01_base_F", 10],
["Boat_Armed_01_base_F", 20],
["Heli_Light_01_base_F", 10],
["Heli_Light_02_base_F", 20],
["Heli_light_03_base_F", 20],
["Heli_Transport_01_base_F", 125],
["Heli_Transport_02_base_F", 130],
["Heli_Transport_03_base_F", 1150],
["Heli_Transport_04_base_F", 130],
["Heli_Attack_01_base_F", 10],
["Heli_Attack_02_base_F", 20],
["Land_Pod_Heli_Transport_04_box_F", 1300],
["Land_CargoBox_V1_F", 500],
["Land_Cargo20_yellow_F", 1000],
["Land_Cargo40_white_F", 2000],
["B_T_VTOL_01_infantry_F", 3000],
["B_T_VTOL_01_vehicle_F", 3000],    <-------- Blackfish Vehicle Transport.
["B_T_VTOL_01_armed_F", 3000],
["O_T_VTOL_02_vehicle_F", 3000],
["C_Offroad_02_unarmed_F", 1000],
["I_C_Offroad_02_unarmed_F", 1000],
["B_T_UAV_03_F", 5000],
["C_Plane_Civil_01_F", 500],
["C_Plane_Civil_01_Racing_F", 850],
["B_CTRG_LSV_01_light_F", 950],
["B_T_LSV_01_unarmed_F", 950],
["B_T_LSV_01_armed_F", 950],
["O_T_LSV_02_unarmed_F", 950],
["O_T_LSV_02_armed_F", 950],
["C_Scooter_Transport_01_F", 1000]

];

And make sure "["B_T_VTOL_01_vehicle_F", 3000]" is listed.

Hope this helps.

Regards

SpeedBirdNam

Well as soon as I put this in the addons\R3F_LOG\config.sqf and restart the server then it breaks the something else where we cannot pick up any boxes or crates or lock anything down. So  we have to weigh the options here and we are disabling this the VTOL loading vehicles until AgentRev can figure it out. One thing is for certain I do appreciate game makers these days because I feel first hand how they feel whenever you fix something in this hand and in the other hand what you just fix breaks something else even though they were not even connected in no way shape or form.

Re: Blackfish Vehicle Transport

« Reply #10 posted: Aug 04, 2016, 10:01 PM »
Nevermind...I forgot to take out <-------- Blackfish Vehicle Transport. that he was showing me which actually breaks picking up crates, boxes and locking stuff...Really weird but true..But its fixed now.

EDIT: I think I know what is going on more than anything. I came on board a few months ago and well they had prebuilt bases built into the mission file itself which is the ONLY way they knew of at the time. They didn't know about the M3editor.

The thing is as Wasteland gets updated they were not updating nothing then if AgentRev updates the Mission file itself well guess what ruins the concept of having a prebuilt base because BIS doesn't allow us to open TWO mission files at once to copy and paste the prebuilt bases from one mission file to another. We use these prebuilt bases all the time. We store our purchased vehicles, ammo boxes and now with new Apex Uniform Boxes we can store a lot of stuff in them which takes away the need to have all these Ammo boxes. Anyway, this is where a lot of our problems are coming in. I am able to fix a lot of stuff, trial and error, over and over and I was finally able to correct the loading of vehicles into the VTOLS but there is going to come a time when we are going to have to start all over and they are going to have to accept reality. But this time I will make sure I will use the M3editor as it actually works in the current EDEN version without crashing and this way I can have a separate sqf just for the bases. Anyway thanks for all your help AgentRev and others.