CUP Weapons/Vehicles/Units

CUP Weapons/Vehicles/Units

« posted: Oct 27, 2016, 08:35 AM »
I recently started up an A3Wasteland server on Altis and i wanted CUP on it. i knew i had CUP installed somewhere so i found out on the Arma 3 launcher that it was installed through workshop, so i clicked view file and it was somewhere in the steamapps/workshop/ folder and i copied everything inside of each folder separately and put it on my desktop as @CUP_Weapons, @CUP_Vehicles, @CUP_Units. I also downloaded @CBA_A3 since cup needs it to work apparently.
i then uploaded the files to my server using Filezilla(FTP) and since my internet is so bad it took 30 hours to upload 7GB to my server.
I then put each mod on the commandline "-mod:@CBA_A3;@CUP_Weapons;@CUP_Vehicles;@CUP_Units". but i just didn't know what to do so i asked around and found out that i had to put the .BIKEY files from the keys folder in each individual mod folder into the main servers "Keys" folder, so i did. i added a few vehicles with the right class name into the store config and they come up in the shop but without a little icon and when you try and buy it, it just says "the order for F-35 (AA) has been cancelled".
It has come to my attention that i have done everything right and i know what i'm doing but it is most likely because its from the workshop folders not downloaded from http://cup-arma3.org/download.
It is a pain to upload but i will do it again if i need to.
It would be much appreciated if someone could link me or make a step by step guide or just tell me what i need to do.

Thanks.
Sam.

P.s. CUP guns and ammo don't show up in the store.
  • Offline Jes
  • First Blood
  • ***
  • Posts: 62

Re: CUP Weapons/Vehicles/Units

« Reply #1 posted: Oct 27, 2016, 04:57 PM »
I have exactly the same problem, I will follow this thread too hoping a clever fellow knows what goes wrong. :)

I´m also using CUP but with Chernarus map and get the same error when buying CUP vehicles i store.
Its only CUP vehicles not spawning. Both weapons and ammo is working fine.

RPT: error says:

Cannot create non-ai vehicle CUP_B_BRDM2_CDF,
Cannot create non-ai vehicle CUP_B_HMMWV_Avenger_USMC,
Cannot create non-ai vehicle CUP_B_HMMVW_MK19_USMC,
Cannot create non-ai vehicle CUP_B_HMMVW_M1114_USMC,
Cannot create non-ai vehicle CUP_B_HMMWV_Unarmed_USMC,
Cannot create non-ai vehicle CUP_B_Jackal2_GMG_GB_W,
Cannot create non-ai vehicle CUP_B_Jackal2_L2A1_GB_W,
Cannot create non-ai vehicle CUP_RG31_MK19,
Cannot create non-ai vehicle CUP_RG31_M2,
Cannot create non-ai vehicle CUP_B_LR_Special_CZ_W,
Cannot create non-ai vehicle CUP_I_SUV_ARMORED_ION,

Any help appreciated.
  • Offline Jes
  • First Blood
  • ***
  • Posts: 62

Re: CUP Weapons/Vehicles/Units

« Reply #2 posted: Oct 28, 2016, 06:14 PM »
Hi SUM BAKED KID,

I found the reason why I got this error.
Check your launch parameter mod names on your server:

-mod=@CBA_A3;@CUP Terrains - Core;@CUP Terrains - Maps;@CUP Units;@CUP Vehicles;@CUP Weapons

I my case I had mispelled @CUP Vehicles with @CUP_Vehicles causing the server not to load the vehicle mod.

Maybe it could be something simular in your case.

Re: CUP Weapons/Vehicles/Units

« Reply #3 posted: Oct 29, 2016, 02:30 PM »
hmm alright i thought the mod parameters needed to have the exact file name with the "_" but i tried this and it still didn't work :/

Did you have your mods in your server folder listed as "@CUP_Vehicles"? (with the underscores)