Antihack

Antihack

« posted: Jul 13, 2014, 05:56 PM »
Is there an Anti hack anyone recommends for Wasteland? That works well with the setting of Wasteland

Re: Antihack

« Reply #1 posted: Jul 13, 2014, 05:57 PM »
there is an antihack feature already implemented in wasteland.

Re: Antihack

« Reply #2 posted: Jul 13, 2014, 06:04 PM »
Well it doesn't work very good. I have other players teleporting and spawning objects so yeah.....
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2600

Re: Antihack

« Reply #3 posted: Jul 13, 2014, 07:49 PM »
Do you have the BattlEye filters installed?

Re: Antihack

« Reply #4 posted: Jul 14, 2014, 03:59 AM »
I thought I did but apparently it isn't. I tried installing BEC every which way it said to do it and have gotten no where. Keep in mind I am NOT running my server via the arma3server.exe link. I am renting a server via a server provider.
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2600

Re: Antihack

« Reply #5 posted: Jul 14, 2014, 04:24 AM »
If your files are uploaded via FTP, normally there should be a "Profiles" folder provided, inside of it should be one or more profiles, and inside the main one should be BattlEye folder, this is where the filters go. Normally the RPT logs are supposed to be located alongside the BE folder you're supposed to use.

Re: Antihack

« Reply #6 posted: Jul 14, 2014, 04:48 AM »
I do have FTP access, but I do not seem to have a "Profiles" folder. Here is a screen shot of the root directory of my server. The server is on the right hand side. http://imgur.com/c5JEQAn
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2600

Re: Antihack

« Reply #7 posted: Jul 14, 2014, 04:51 AM »
Can you try to search for.RPT files on that FTP?

Re: Antihack

« Reply #8 posted: Jul 14, 2014, 05:20 AM »
Yes. There are .rpt files in my cfg folder, within the cfg folder is also a BattleEye folder that contains these files: "BEServer_active_6873.cfg", "BEServer.dll", and "bans.txt"
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2600

Re: Antihack

« Reply #9 posted: Jul 14, 2014, 05:24 AM »
You should put the filters there, restart your server, then try to create a vehicle with the admin menu to confirm if it works.

Re: Antihack

« Reply #10 posted: Jul 14, 2014, 05:31 AM »
I'm sorry, filters? Filters from BEC, or do I need to download filters from BE?
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2600