Can't disable 'show kills in chat'

  • Offline night
  • First Blood
  • ***
  • Posts: 97

Can't disable 'show kills in chat'

« posted: Apr 27, 2018, 12:51 PM »
Hey, turning it on and off and kills still show in chat regardless if killfeed is on.
  • Offline Mokey
  • Fractured Wasteland
  • Elite
  • ******
  • Posts: 606
  • Https://Fractured-Gaming.com

Re: Can't disable 'show kills in chat'

« Reply #1 posted: Apr 27, 2018, 01:36 PM »
Code: [Select]
DeathMessages=0;Add/Change that in your arma 3 server profile settings. That should disable chat death messages.
Posts once, edits post 40 times in 60 seconds. STUPID FAT FINGERS!
  • Offline night
  • First Blood
  • ***
  • Posts: 97

Re: Can't disable 'show kills in chat'

« Reply #2 posted: Apr 27, 2018, 01:37 PM »
No no, players want to disable it for themselves and it doesn't work. Not server-wide :)
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2495

Re: Can't disable 'show kills in chat'

« Reply #3 posted: Apr 27, 2018, 10:58 PM »
There are 2 types of death messages, engine messages and mission messages. The "Show kills in chat'" checkbox only controls mission messages. If your game language is set to English, both look identical in the chat. They never appear at the same time, it's always either engine or mission messages but not both.

If you haven't explicitly set deathMessages=0 in the server Arma3Profile, engine messages are permanently shown and thus mission messages are not shown. In this case, the checkbox has no effect. I guess I should clarify it by making the checkbox grayed out.
  • Offline night
  • First Blood
  • ***
  • Posts: 97

Re: Can't disable 'show kills in chat'

« Reply #4 posted: Apr 28, 2018, 02:11 AM »
Got it, thanks!