ExtDB Error

ExtDB Error

« posted: Aug 22, 2018, 12:01 PM »
hi i tried to install an wasteland server but all i got is this. My server is running on Linux.

To start the server i use an shell script where i add this startcommand
Code: [Select]
-port=2302 -filePatching -cfg=/home/arma3server/serverfiles/cfg/arma3server.network.cfg -config=/home/arma3server/serverfiles/cfg/arma3server.server.cfg -mod= -servermod=mods/@extDB3 -bepath= -autoinit -loadmissiontomemory

Code: [Select]

[14:16:55 +02:00] [Thread 9653] extDB3: Database Type: a3wasteland: No such node (a3wasteland.IP)
[14:16:55 +02:00] [Thread 9653] extDB3: SQL_CUSTOM: No Database Connection: a3wasteland
[14:16:55 +02:00] [Thread 9653] extDB3: Failed to Load Protocol: SQL_CUSTOM

Code: [Select]
13:31:49 CallExtension loaded:   extDB3 (/home/arma3server/serverfiles/@extDB3/extDB3.so) [▒▒▒I▒\▒]

13:31:49 "extDB3 Loaded"
13:31:49 "---------------------------------------------------------------------"
13:31:49 "---------------------------------------------------------------------"
13:31:49 a3\structures_f\mil\flags\flag_asym_f.p3d: No geometry and no visual shape
13:31:49 Strange convex component16 in a3\boat_f_jets\carrier_01\carrier_01_hull_05_2_f.p3d:geometry
13:31:49 Strange convex component17 in a3\boat_f_jets\carrier_01\carrier_01_hull_05_2_f.p3d:geometry
13:31:49 Strange convex component197 in a3\boat_f_jets\carrier_01\carrier_01_hull_06_2_f.p3d:geometryFire
13:31:49 Strange convex component199 in a3\boat_f_jets\carrier_01\carrier_01_hull_06_2_f.p3d:geometryFire
13:31:49 Strange convex component41 in a3\boat_f_jets\carrier_01\carrier_01_hull_09_1_f.p3d:geometryView
13:31:49 Strange convex component42 in a3\boat_f_jets\carrier_01\carrier_01_hull_09_1_f.p3d:geometryView
13:31:49 Strange convex component43 in a3\boat_f_jets\carrier_01\carrier_01_hull_09_1_f.p3d:geometryView
13:31:49 Strange convex component44 in a3\boat_f_jets\carrier_01\carrier_01_hull_09_1_f.p3d:geometryView
13:31:49 Strange convex component45 in a3\boat_f_jets\carrier_01\carrier_01_hull_09_1_f.p3d:geometryView
13:31:49 Strange convex component46 in a3\boat_f_jets\carrier_01\carrier_01_hull_09_1_f.p3d:geometryView
13:31:49 a3\data_f\proxies\flags\flag_auto.p3d: No geometry and no visual shape
13:31:49 a3\weapons_f\binocular\nvg_proxy.p3d: No geometry and no visual shape
13:31:49 a3\characters_f\heads\glasses\g_shades_black.p3d: No geometry and no visual shape
13:31:49 a3\characters_f_beta\heads\glasses\g_shades_green.p3d: No geometry and no visual shape
13:31:49 Land_PipeFence_01_m_gate_v1_closed_F: door_1_locked_rot - unknown animation source door_1_locked_source
13:31:50 Mission read.
13:31:50 Connected to Steam servers
Wrong init state
13:31:50 ../lib/Network/networkServer.cpp OnClientStateChanged:NOT IMPLEMENTED - briefing!
13:31:50  Mission id: c5d3e29c94d2bc8d356872ced020a3a2af497968
13:31:50 Game started.
Attempt to override final function - bis_fnc_storeparamsvalues_data
13:31:50 Land_PipeFence_01_m_gate_v2_closed_F: door_1_locked_rot - unknown animation source door_1_locked_source
13:31:50 Land_PipeFence_01_m_gate_v2_closed_F: door_2_locked_rot - unknown animation source door_2_locked_source
Attempt to override final function - a3w_fnc_getteammarkercolor
13:31:50 "############################# ArmA3_Wasteland #############################"
13:31:50 "WASTELAND SERVER - Initializing Server"
13:31:50 Strange convex component202 in a3\structures_f\households\house_small01\d_house_small_01_v1_f.p3d:geometryView
13:31:50 Strange convex component203 in a3\structures_f\households\house_small01\d_house_small_01_v1_f.p3d:geometryView
13:31:50 Warning Message: Script addons\proving_ground\CfgExplorer2\scripts\showConfig.sqf not found
13:31:50 Weather was forced to change
13:31:50 Warning Message: Script \A3Wasteland_settings\antihack\payload.sqf not found
13:31:50 "ANTI-HACK: External payload unavailable, using internal payload"
13:31:51 "ANTI-HACK: Started."
13:31:51 "WASTELAND SERVER - Initializing Server Vars"
13:31:51 "WASTELAND SERVER - Initializing Server Compile"
13:31:51 "WASTELAND SERVER - Initializing Server Relations"
13:31:51 "WASTELAND SERVER - Server Compile Finished"
13:31:51 "[INFO] extDB3 v1.022 extension loaded"
13:31:51 "[extDB3] Startup..."
13:31:51 "[extDB3] ███ Database error, check @extDB3\logs -- [0,""Database Config Error""]"
13:31:51 "[extDB3] ███ SQL_CUSTOM Protocol error, check @extDB3\logs -- [0,""Failed to Load Protocol""]"
13:31:51 "[extDB3] ███ ERROR - Startup aborted"



This is my Files structure


Can someone help me.

best regards
Russ3lHD

Re: ExtDB Error

« Reply #1 posted: Aug 24, 2018, 02:26 AM »
You forgot to setup the sql server and probably the database structure in it.

As you`re using linux, I also would recommend you to remove any @ and capital letters from the directory (rename @extDB3 to extdb3). Apparently not the problem in this case, just a tip  ;)