[SOLVED] Code for Sochor not working

[SOLVED] Code for Sochor not working

« posted: Aug 30, 2021, 06:54 AM »
Hello All It seems that I have an issue with the Sochor not loading mines.  Is this code proper and it the only place that need changed is in the Vehicleloadouts in the Modconfig file? here is the code.

Code: [Select]
// Sochor
case (_class isKindOf "O_MBT_02_arty_F"):
{
_mags =
[
["32Rnd_155mm_Mo_shells_O", [0]],
["2Rnd_155mm_Mo_guided_O", [0]],
["96Rnd_40mm_G_belt", [0]],
["2Rnd_155mm_Mo_Cluster_O", [0]],
["6Rnd_155mm_Mo_smoke_O", [0]],
["6Rnd_155mm_Mo_AT_mine_O", [0]],
["6Rnd_155mm_Mo_mine_O", [0]],
["SmokeLauncherMag", [0]],
["4Rnd_155mm_Mo_LG_O", [0]]
];
_weapons =
[
["mortar_155mm_AMOS", [0]],
//["HMG_127_APC", [0]],
//["GMG_40mm", [0]],
["SmokeLauncher", [0]]
];

Re: Code for Sochor not working

« Reply #1 posted: Aug 30, 2021, 05:10 PM »
Hi, did you copy whole "sochor loadout" ?? if its all then there is missing array on botom
look at mine at the botom
Code: [Select]
case (_class isKindOf "O_MBT_02_arty_F"):
        {

             _weapons =
            [
                ["HMG_127_APC",[0,0]],
                ["mortar_155mm_AMOS", [0]],
["GMG_40mm",[0,0]],
["HMG_127_APC", [1]]
            ];
            _mags =
            [
//
                ["32Rnd_155mm_Mo_shells_O", [0]],
                ["2Rnd_155mm_Mo_guided_O",[0]],
                ["4Rnd_155mm_Mo_LG_O",[0]],
                ["6Rnd_155mm_Mo_smoke_O",[0]],
                ["6Rnd_155mm_Mo_mine",[0]],
                // added back from previous version
                ["200Rnd_127x99_mag_Tracer_Green", [0,0]],
                ["200Rnd_127x99_mag_Tracer_Green", [0,0]],
                ["96Rnd_40mm_G_belt", [0,0]]


            ];

      }; ←this array   

and just in advice dont forget to add commanders gun + mags [0, 0] , otherwise comander will have empty turret

Re: Code for Sochor not working

« Reply #2 posted: Aug 30, 2021, 10:06 PM »
Thank you for replying. Its not showing and I even copied the code you had put in. It must be somewhere else that needs edited that im missing to be able to show the ammo type. Here is what I see in the vehicle.

Re: Code for Sochor not working

« Reply #3 posted: Aug 31, 2021, 12:11 AM »
Can anyone Please tell me if I am missing something? As to why this will not load or show the ammo in this Sochor?

Re: Code for Sochor not working

« Reply #4 posted: Aug 31, 2021, 03:12 PM »
that is strange, when i try to add/delete AT mines it will show up. just in case can you send here your vehicleLoadouts.sqf file ?

Re: Code for Sochor not working

« Reply #5 posted: Sep 01, 2021, 09:24 AM »
Its gonna sound silly but it was a wrong name of the vehicle. I corrected the issue thank you for taking time to help me.