Trying to add wasteland to our server

Trying to add wasteland to our server

« posted: Oct 27, 2014, 07:52 PM »
Me and a friend just rented a ARMA 3 server from gamerservers.com and would like to add wastelands to it but as this is my first time actually setting up something like this im in need of some assistance to do so!  If anyone could shed some light on this matter it would be most appreciated!
  • Offline micovery
  • Moderator
  • Hardened
  • ******
  • Posts: 159

Re: Trying to add wasteland to our server

« Reply #1 posted: Oct 27, 2014, 09:29 PM »
Did you rent a managed, or unmanaged server?

managed means that the hosting provider manages the server for you, and all you get is usually a control panel kind of access, and FTP.

unmanaged means that the hosting provider gives you full access to the operating system of the box (or VM)


I am guessing you do want to have objects, and vehicles persisted in your mission across restarts.


For managed servers, I think your only choice is to use profileNamespace for saving (need clarification on this ... anyone using iniDB on a managed server?)



For unmanaged servers, you got a few choices:


1. The official mission, using iniDB for persistence

Source code at: https://github.com/A3Wasteland/ArmA3_Wasteland.Altis
Released PBOs at: https://github.com/A3Wasteland/Release_Files

Old thread with some instructions: http://forums.a3wasteland.com/index.php?topic=117.0


2. The yet-to-be-official fork using extDB (and MySQL) for persistence

Source code at: https://github.com/Torndeco/ArmA3_Wasteland.Altis
Released PBOs: you have to build the PBO yourself from the source

No setup instructions that I know of?


3. Non-official fork that I maintain using Node.js (and your choice of database) for persistence

Source code, and Linux instructions at: https://github.com/micovery/ArmA3_Wasteland.Altis/tree/v1_beta


If you've never setup a server before, this information is probably not very useful to you. I'd recommend you first setup the vanilla mission using profileNamespace, then move on to the more advanced persistence solutions.

Re: Trying to add wasteland to our server

« Reply #2 posted: Oct 28, 2014, 12:26 AM »
Don't use the extDB github version

It is outof date...
Rev done alot of changes recently + license change aswell.
The extDB version is more of a example of how to add in extDB support at this point.
If/When Rev adds it to offical Repo.

You can look @ lodac repo for A3Wasteland with extDB code, plus its more upto date etc...
Might need to bug him for Database scheme though...
So i really dont recommend extDB version if you are new to Arma Server Hostings + SQF Code etc..

But honestly just try to get offical A3Wasteland to work first

-----------------

Also helps to describe what you are stuck on
Getting A3Wasteland to run ?
Setting up server settings ?
Persistence ?

Re: Trying to add wasteland to our server

« Reply #3 posted: Oct 28, 2014, 06:47 PM »
we are managing the server ourselves and im going to be doing all the FTP work myself
  • Offline micovery
  • Moderator
  • Hardened
  • ******
  • Posts: 159

Re: Trying to add wasteland to our server

« Reply #4 posted: Oct 28, 2014, 07:02 PM »
we are managing the server ourselves and im going to be doing all the FTP work myself

Not entirely clear ... Is it a Windows, or Linux machine?

Can you connect remotely to the machine with one of these:

For Windows it's usually Remote Desktop Protocol (RDP).
For Linux it's usually SSH, and sometimes VNC.

?

If all the access you have is  FTP + Control Panel...then it means that the gameservers.com manages the machine for you (hence the term "managed").

You only get to control the files in the Arma 3 directory, and starting/stopping the Arma 3 server process.


From your description, it seems that you are on a "managed" box. As Torndeco suggested earlier, you should grab the vanilla/official PBO first.

1. Drop the PBO in the Arma 3 "MPMissions" directory (within the Arma 3 main directory)
2. Drop the "A3Wasteland_settings" folder in the Arma 3 main directory.
3. Modify your server config file to refer to the wasteland PBO.

Re: Trying to add wasteland to our server

« Reply #5 posted: Oct 30, 2014, 08:10 AM »
thanks to all your help we now have basic Atlis Wasteland on our server and i was wondering if anyone knew how to add ATM and vehicle saving??

Re: Trying to add wasteland to our server

« Reply #6 posted: Oct 30, 2014, 10:08 AM »
If you use a later than 0.9hi release, suggest you put in the latest (1.0) from release files and put the A3Wasteland_settings folder in the server root folder i think vehicle saving is on by default, otherwise its in the main_config.sqf which is in the A3Wasteland_settings folder, you should really try to get this settings folder to works as its in that one you can easily customize most features, its very neat if you get it right, if you set startmoney to something odd like 133 you will know if it worked on respawn / first spawn.

https://github.com/A3Wasteland/Release_Files

Re: Trying to add wasteland to our server

« Reply #7 posted: Oct 30, 2014, 02:42 PM »
will updating it to 1.0 have default vehicle saving and ATM banking both ??  or will i have to add anything else?

Re: Trying to add wasteland to our server

« Reply #8 posted: Oct 30, 2014, 03:00 PM »
i updated it to 1.0 and still no vehicle saving or ATM banking system anyone know where i could get those files and where they go or what i have to edit?

Re: Trying to add wasteland to our server

« Reply #9 posted: Oct 30, 2014, 04:15 PM »
ATMs are not in but vehicles save fine, ofc its the vehicles from the vehicleshop or vehicles captured in missions. If they don't save for you there is something missing.

you can save money in the ammoboxes but our need to lock them so they save.

Does anything save for you?

BTW I rented a server from Pingperfect before and they didn't allow for uploading certain files but after I asked they gave me permissions for a couple of different files among others .dll

Re: Trying to add wasteland to our server

« Reply #10 posted: Oct 30, 2014, 04:30 PM »
i have permissions to upload any files i want just need to know what else i can add.... is there a file for selling vehicles?

Re: Trying to add wasteland to our server

« Reply #11 posted: Oct 30, 2014, 05:03 PM »
Well i use something i hopefully i improved upon from, Lodac, Wiking, Gigateks ChopShop.sqf for selling vehicles

it works by adding a action to the player if you look at a certain item in game while in the vehicle, its very simple to add but you need to edit the playerActions.sqf for it to work as is. Would you like me to share that?

For the file structures on the server (thought i post em here as someone else also asked), now this is for a server where you have full access. Rented servers may not have exactly the same files in here, i also use -profiles in my startup so i have some things in another folder if thats interesting
Code: [Select]
-profiles=C:\Arma3Server\Wasteland\SNAFU -name=SNAFUSERVER
This gives you an idea of the server setup
https://community.bistudio.com/wiki/Arma_3_Dedicated_Server

Server root folder

A3Wasteland_settings


See where i put the iniDB.dll, DB folder and the A3Wasteland_settings folder.
I think that if you dont have the iniDB.dll it saves in the server profile
 file for the server/user in my case "SNAFUSERVER.vars.Arma3Profile" where SNAFUSERVER would be
something else for you.

You need iniDB.dll from the release files and you need to create the DB folder (it may create now but im not sure).

The A3Wasteland_settings folder is important as it contains a cuple of important files, the ones you need to touch is main_config.sqf and maybe admins.sqf but main_config.sqf is where you do all your settings.

Hope this helps a bit

Re: Trying to add wasteland to our server

« Reply #12 posted: Oct 30, 2014, 05:57 PM »
if you could share that then i would be grateful!  and yes ty u have been alot of help settin this all up

Re: Trying to add wasteland to our server

« Reply #13 posted: Oct 30, 2014, 06:00 PM »
so far the only thing ive added is the altis 1.0 .pbo and the wasteland settings folder and edited config to load the mission whats my next step?

Re: Trying to add wasteland to our server

« Reply #14 posted: Oct 30, 2014, 06:53 PM »
Make sure vehicle saving is on in the main_config and start it up with so few mods you can, if that works well look at adding the sell vehicle stuff