A3 Wasteland New to this

A3 Wasteland New to this

« posted: Nov 01, 2014, 12:37 AM »
So Ive run into some problems, I cant get my server to Autorun the Wasteland PBO upon restarting it. It instead takes you to the voting page when you join the server. Any help would be great
  • Offline Caffeind
  • Insurgent
  • Fresh Spawn
  • *
  • Posts: 14

Re: A3 Wasteland New to this

« Reply #1 posted: Nov 01, 2014, 02:47 AM »
Not sure if this is your problem or not, but ensure you are following the ArmA3 protocols for the missions class in the server .cfg file (at the bottom of the .cfg file you should find your class missions {})

Code: [Select]
class Missions
{
class AA3WL // name for the mission, can be anything
{
template = "A3Wasteland_v0.9g.Altis"; // omit the .pbo suffix and change name to your .pbo version.
difficulty = "Veteran";
};
}
Thread softly and carry a big sig!

Re: A3 Wasteland New to this

« Reply #2 posted: Nov 01, 2014, 03:20 AM »
Not sure if this is your problem or not, but ensure you are following the ArmA3 protocols for the missions class in the server .cfg file (at the bottom of the .cfg file you should find your class missions {})

Code: [Select]
class Missions
{
class AA3WL // name for the mission, can be anything
{
template = "A3Wasteland_v0.9g.Altis"; // omit the .pbo suffix and change name to your .pbo version.
difficulty = "Veteran";
};
}

This is what I have.


// MISSIONS CYCLE (see below)
class Missions  {
    class Wasteland  {
        template="A3Wasteland_v0.9gh.stratis";
        difficulty="Regular";
    };
};
Help?
  • Offline Caffeind
  • Insurgent
  • Fresh Spawn
  • *
  • Posts: 14

Re: A3 Wasteland New to this

« Reply #3 posted: Nov 01, 2014, 04:17 AM »
This is what I have.


// MISSIONS CYCLE (see below)
class Missions  {
    class Wasteland  {
        template="A3Wasteland_v0.9gh.stratis";
        difficulty="Regular";
    };
};
Help?

When you join your server, is the Wasteland mission available for voting?

Are you sure you have a mission file named "A3Wasteland_v0.9gh.stratis.pbo" in your 'mpmissions' folder?

There could be an error in your .cfg file before the class Missions {} that is preventing it from getting to the missions cycle (this one is just a guess).

I had the same problem once, and I'm sure it was just syntax on my end that was the problem.
Thread softly and carry a big sig!

Re: A3 Wasteland New to this

« Reply #4 posted: Nov 01, 2014, 04:29 AM »
This is what I have.


// MISSIONS CYCLE (see below)
class Missions  {
    class Wasteland  {
        template="A3Wasteland_v0.9gh.stratis";
        difficulty="Regular";
    };
};
Help?

When you join your server, is the Wasteland mission available for voting?

Are you sure you have a mission file named "A3Wasteland_v0.9gh.stratis.pbo" in your 'mpmissions' folder?

There could be an error in your .cfg file before the class Missions {} that is preventing it from getting to the missions cycle (this one is just a guess).

I had the same problem once, and I'm sure it was just syntax on my end that was the problem.

It's available for voting, however I dont want the vote option. I just want the server to auto launch it

Re: A3 Wasteland New to this

« Reply #5 posted: Nov 01, 2014, 03:17 PM »
Only voting option i have is "voteMissionPlayers = 1;" and i also only have one mission. that loads the mission at once.