Loot Spawn time / trigger ?!

Loot Spawn time / trigger ?!

« posted: Dec 24, 2014, 02:23 PM »
Hi there!

First of all i must say i love this Wasteland from you :) (I have A3Wasteland_v1.0b.Altis on my server)

But i have a question:

What is the "trigger" that spawns loot in buildings?

Sometimes i run thru a whole town, searching every building and there is no loot.

Then i make a 180° turn and run my track back and then the loot is spawning .... takes sometimes over 10 minutes ?!

So what is the trigger that says my server: "Now u can spawn loot" ?

Regards from germany and sorry for my poor english...

H03LL3
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2581

Re: Loot Spawn time / trigger ?!

« Reply #1 posted: Dec 24, 2014, 08:08 PM »
For loot to spawn, your player or vehicle must be traveling below 6 m/s (21.6 km/h). If that is the case, then every 10 seconds, a loot spawning request is sent for all buildings within 50m to the server. The server goes through all of those buildings, and for each building that didn't have loot spawn within the last 30 minutes, then a new batch of loot spawns in it. By default, there is 25% chance of a loot drop for each position inside a building. Loot spawning can become sluggish if there's a lot of stuff going on the server.

Re: Loot Spawn time / trigger ?!

« Reply #2 posted: Dec 25, 2014, 04:14 PM »
Thx AgentRev for your reply!

Ok, understood!

Have you any idea, why sometimes after restart my servr needs so much time for reloading, especially the lootspawner, see here and watch the Times!

-- LOOTSPAWNER LSusedclass_list ready, d: 409.077s

Code: [Select]
16:00:45 "WASTELAND SERVER - Initializing Server Spawning"
16:00:46 "-- LOOTSPAWNER initialise ------------------------"
16:00:46 "-- LOOTSPAWNER spawnBuilding_list ready, d: 0s"
16:00:51 "Creating territory capture trigger for 'TERRITORY_SW_AIRFIELD'"
16:00:51 "Creating territory capture trigger for 'TERRITORY_MAIN_AIRBASE_SW'"
16:00:51 "Creating territory capture trigger for 'TERRITORY_MAIN_AIRBASE_CENTER'"
16:00:51 "Creating territory capture trigger for 'TERRITORY_MAIN_AIRBASE_NE'"
16:00:51 "Creating territory capture trigger for 'TERRITORY_NW_AIRFIELD'"
16:00:51 "Creating territory capture trigger for 'TERRITORY_NE_AIRFIELD'"
16:00:51 "Creating territory capture trigger for 'TERRITORY_SE_AIRFIELD'"
16:00:51 Strange convex component24 in a3\structures_f\households\house_small02\i_house_small_02_v1_dam_f.p3d:geometryView
16:00:52 "Creating territory capture trigger for 'TERRITORY_WEST_POWER_PLANT'"
16:00:52 "WARNING: No config_territory_markers definition for marker 'TERRITORY_EAST_POWER_PLANT_1'. Deleting it!"
16:00:52 "Creating territory capture trigger for 'TERRITORY_SALTFLATS_AIRFIELD'"
16:00:52 "Creating territory capture trigger for 'TERRITORY_THRONOS_CASTLE'"
16:00:52 "WARNING: No config_territory_markers definition for marker 'TERRITORY_KASTRO_CASTLE'. Deleting it!"
16:00:52 Strange convex component57 in a3\structures_f\households\house_small03\i_house_small_03_v1_dam_f.p3d:geometryPhys
16:00:52 "Creating territory capture trigger for 'TERRITORY_CENTER_POWER_PLANT'"
16:00:52 "Creating territory capture trigger for 'TERRITORY_IRAKLIA_RUINS'"
16:00:52 "Creating territory capture trigger for 'TERRITORY_ARTINARKI_RUINS'"
16:00:52 "WARNING: No config_territory_markers definition for marker 'TERRITORY_NE_TRANSMITTER'. Deleting it!"
16:00:52 "WARNING: No config_territory_markers definition for marker 'TERRITORY_SE_TRANSMITTER_1'. Deleting it!"
16:00:52 "WARNING: No config_territory_markers definition for marker 'TERRITORY_SE_TRANSMITTER_2'. Deleting it!"
16:00:52 "Creating territory capture trigger for 'TERRITORY_MAGOS_TRANSMITTER'"
16:00:52 "Creating territory capture trigger for 'TERRITORY_PYRSOS_TRANSMITTER'"
16:00:52 "Creating territory capture trigger for 'TERRITORY_MILITARY_RESEARCH'"
16:00:54 "WASTELAND SERVER - 16 Static helis Spawned"
16:00:55 "requestPlayerData: [R Alpha 1-2:1 (H03LL3) REMOTE,3,R Alpha 1-2:1 (H03LL3) REMOTE]"
16:00:58 Error: Object(3 : 6) not found
16:00:58 Error: Object(3 : 7) not found
16:01:00 Strange convex component24 in a3\structures_f\households\house_small02\u_house_small_02_v1_dam_f.p3d:geometryView
16:01:09 Strange convex component322 in a3\structures_f\research\dome_big_f.p3d:geometryFire
16:01:09 Strange convex component327 in a3\structures_f\research\dome_big_f.p3d:geometryFire
16:01:30 "-- LOOTSPAWNER Buildingpositions_list ready, d: 44.193s"
16:04:34 "A3Wasteland - world persistence loaded 33 objects from iniDBI"
16:07:40 "A3Wasteland - world persistence loaded 1 vehicles from iniDBI"
16:08:19 "-- LOOTSPAWNER LSusedclass_list ready, d: 409.077s"
16:08:19 "-- LOOTSPAWNER LSDer started..."
16:09:24 "WASTELAND - Vehicle spawning completed - 502 Vehicles Spawned"
16:10:20 "WASTELAND SERVER - 4 Planes Spawned"
16:12:11 "WASTELAND SERVER - 15 Boats Spawned"
  • Offline lodac
  • Hardened
  • ****
  • Posts: 220
  • TOP Arma Server Admin

Re: Loot Spawn time / trigger ?!

« Reply #3 posted: Dec 25, 2014, 04:53 PM »
Thx AgentRev for your reply!

Ok, understood!

Have you any idea, why sometimes after restart my servr needs so much time for reloading, especially the lootspawner, see here and watch the Times!


16:09:24 "WASTELAND - Vehicle spawning completed - 502 Vehicles Spawned"


Vehicle spawning takes a long time

TOPArma Mission - Share your mission on GitHub
  • Offline CREAMPIE
  • Armaholic
  • Veteran
  • ******
  • Posts: 1083
  • ^_^;;

Re: Loot Spawn time / trigger ?!

« Reply #4 posted: Jan 03, 2015, 08:29 AM »
@Agentrev


Having ported over A3W to the new X-CAM prototype map I had to add some new building classes to the LSlootBuildings.sqf array to get loot to populate.

I noticed then that some of the buildings don't have spawn locations in my RPT - i take it this is defined in the vehicleclass for that building and if i REALLY wanted to fix that will have to define a custom class with those attributes?

It's not a major thing, just 2 - 3 of the "less common" buildings ....

Thanks CP

- from the grassy knoll -
  • Offline AgentRev
  • Developer
  • Veteran
  • ******
  • Posts: 2581

Re: Loot Spawn time / trigger ?!

« Reply #5 posted: Jan 03, 2015, 08:43 AM »
You cannot define custom positions, not without significant reworking of the loot scripts. All building positions are hardcoded in their respective 3D model, and it's the only thing that the lootspawner currently handles.
  • Offline CREAMPIE
  • Armaholic
  • Veteran
  • ******
  • Posts: 1083
  • ^_^;;

Re: Loot Spawn time / trigger ?!

« Reply #6 posted: Jan 03, 2015, 11:33 AM »
You cannot define custom positions, not without significant reworking of the loot scripts. All building positions are hardcoded in their respective 3D model, and it's the only thing that the lootspawner currently handles.

cool thanks ! I have removed the buildings that were showing up without spawn locations ! I suspect there are still some issues with some of the vehicle classes as I am seeing alot of spam in my RPT for this :



Code: [Select]
Object id 8ca5e409 (1033) not found in slot 188,101
Link cannot be resolved
Object id 8c45c3cf (975) not found in slot 184,98
Link cannot be resolved
"TERRITORY SYSTEM: _realLoopTime was 10.124"
"A3W - 13 vehicles have been saved with iniDBI"
Object id 8ca5e409 (1033) not found in slot 188,101
Link cannot be resolved
Object id 8c45c3cf (975) not found in slot 184,98
Link cannot be resolved
"TERRITORY SYSTEM: _realLoopTime was 10.0967"
Object id 8ca5e409 (1033) not found in slot 188,101
Link cannot be resolved
"TERRITORY SYSTEM: _realLoopTime was 10.0566"
Object id 8ca5e409 (1033) not found in slot 188,101
Link cannot be resolved
"TERRITORY SYSTEM: _realLoopTime was 10.0381"
"A3W - 4 baseparts and objects have been saved with iniDBI"
Object id 8ca5e409 (1033) not found in slot 188,101
Link cannot be resolved
"TERRITORY SYSTEM: _realLoopTime was 10.0391"
Object id 8ca5e409 (1033) not found in slot 188,101
Link cannot be resolved
"TERRITORY SYSTEM: _realLoopTime was 10.0762"

- from the grassy knoll -